I am installing Mint 17.1 (MATE) on my MacBook Pro Retina (due to it having much better hardware than my PC, on which I successfully installed Mint 17.1 in the past).

I followed the instructions from this tutorial.

Everything goes great until the ability to connect to my WiFi. I followed the steps in the tutorial:

From the menu, run Administration -> Driver Manager The Driver Manager warns that it cannot install drivers... (because we're offline) Plug in the Linux Mint USB stick you used to install the operating system. Once it's mounted, press the "OK" button in the Driver Manager to dismiss the warning. Select the "bcmwl-kernel-source" driver Press "Apply changes"

So when I insert the Mint USB, the Warning message does indeed go away, but when I press "Apply Changes" , it shows a loading bar for just a second, but then goes right back to the old selection. I tried restarting it, with no luck.

The funny thing is, when I tried the above method when I was running just from the USB before the install, I was able to select the bcmwl-kernel-source and connect to the WiFi. It was only after the install was successfully completed that I could not repeat this.

Any and all help is really appreciated!

3 Answers 3


I was having the same problem with Linux Mint Rafaela on a Compaq Mini 110. In the Driver manager, when I tried to use bcmlw-kernel-source, the driver manager unselected it automatically, therefore no driver was being activated.

The solution was to install it in the hard drive and once the system was installed I was able to select the driver.


and welcome to Unix & Linux Stackexchange.

Getting GNU/Linux and wifi drivers to play nicely together can be truly frustrating, I know. I am having issues myself with one Broadcomm and one Qualcomm set, on two different boxes). Haven't been fiddling with Mint though, but I hope I can give some pointers anyway.

Have you tried downloading the bcmwl-kernel-source to a USB and transfer the files to the wifi-less box, install it and then redo the procedure? If not, you can find it here together with comments from other Mint users with broadcomm issues.

The fact that you were able to get the wifi to work in the live environment, may also indicate that you lack something in the HDD install that was present on the live disc but that didn't get installed. I don't know much about Mint, but other distros allow you to choose what you want to install rather than installing everything on the live iso.

As they conclude over here at the linuxmint community (in the second of the comments, counting from the top), b43-fwcutter has to be installed as well. Could very well be that it is included in the live system, but doesn't get installed by default for some reason. If that is the case, it would be logical that you can get the wifi to work on the live USB, but not when the distro is installed. You can find b43-fwcutter here. You will possibly also need broadcom-wl- - although the content may or may not be included in the bcmwl-kernel-source. When you have installed these on your box, try to redo everything and see if it works.

I hope you have some good news to share next time I check this question again! Now I am off to fix my own wifi issues, all while cursing every single manufacturer that doesn't have GNU/Linux users in mind when they make their products.

  • You might need dkms as well, when trying to install the bcmwl-kernel-source, so get that on a USB too.
    – fantasia
    Jul 9, 2015 at 20:44

Uninstall the bcmwl-kernel-source package by issuing the following command on a terminal:

sudo apt-get remove bcmwl-kernel-source

Make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

sudo apt-get install firmware-b43-installer b43-fwcutter


cat /etc/modprobe.d/* | egrep 'bcm'

(you may want to copy this) and see if the term 'blacklist bcm43xx' is there

If it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

put a # in front of the line: blacklist bcm43xx.


Tried and tested by me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.