12

I am trying to send mail to my test GMail account using Postfix (default Debian setup), and I am failing ("/var/log/mail.log"):

Sep 26 16:13:43 sugarmailer postfix/smtpd[1473]: connect from localhost[127.0.0.1]
Sep 26 16:13:44 sugarmailer postfix/smtpd[1473]: 07C8C3C04BE: client=localhost[127.0.0.1]
Sep 26 16:13:44 sugarmailer postfix/cleanup[1478]: 07C8C3C04BE: message-id=<20110926141344.07C8C3C04BE@sugarmailer>
Sep 26 16:13:44 sugarmailer postfix/qmgr[1446]: 07C8C3C04BE: from=<wena@sugarmailer>, size=356, nrcpt=1 (queue active)
Sep 26 16:13:44 sugarmailer postfix/smtpd[1473]: disconnect from localhost[127.0.0.1]
Sep 26 16:13:52 sugarmailer postfix/smtp[1479]: 07C8C3C04BE: to=<[email protected]>, relay=gmail-smtp-in.l.google.com[209.85.227.26]:25, delay=8.4, delays=0.07/0.03/0.73/7.6, dsn=5.7.1, status=bounced (host gmail-smtp-in.l.google.com[209.85.227.26] said: 550 5.7.1 smtp-proxy1.wa.co.za Message marked as SPAM, denied [7.600000] (in reply to end of DATA command))
Sep 26 16:13:52 sugarmailer postfix/cleanup[1478]: 822113C04D3: message-id=<20110926141352.822113C04D3@sugarmailer>
Sep 26 16:13:52 sugarmailer postfix/qmgr[1446]: 822113C04D3: from=<>, size=2334, nrcpt=1 (queue active)
Sep 26 16:13:52 sugarmailer postfix/bounce[1480]: 07C8C3C04BE: sender non-delivery notification: 822113C04D3
Sep 26 16:13:52 sugarmailer postfix/qmgr[1446]: 07C8C3C04BE: removed
Sep 26 16:13:52 sugarmailer postfix/local[1482]: 822113C04D3: to=<wena@sugarmailer>, relay=local, delay=0.08, delays=0.03/0.03/0/0.02, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 26 16:13:52 sugarmailer postfix/qmgr[1446]: 822113C04D3: removed

Gmail thinks that this may be spam, and is therefore undeliverable. Here's the specific message:

<[email protected]>: host gmail-smtp-in.l.google.com[209.85.229.26] said:
    550 5.7.1 smtp-proxy1.wa.co.za Message marked as SPAM, denied [7.600000]
    (in reply to end of DATA command)

Note that exim4 works (with internet site debconf setting, but everything else left at default), though Gmail puts the mail into Spam folder ("/var/log/exim4/mainlog"):

2011-09-26 16:20:24 1R8C2i-0000cr-QV <= wena@sugarmailer H=localhost ([127.0.1.1]) [127.0.0.1] P=esmtp S=370
2011-09-26 16:20:25 1R8C2i-0000cr-QV ** [email protected] R=nonlocal: Mailing to remote domains not supported
2011-09-26 16:20:25 1R8C2j-0000ct-H4 <= <> R=1R8C2i-0000cr-QV U=Debian-exim P=local S=1189
2011-09-26 16:20:25 1R8C2i-0000cr-QV Completed
2011-09-26 16:20:26 1R8C2j-0000ct-H4 => wena <wena@sugarmailer> R=local_user T=mail_spool
2011-09-26 16:20:26 1R8C2j-0000ct-H4 Completed

One other note is that local delivery works without a problem.

So, the question, what is it in Exim4 that enables it pass through Gmail servers while Postfix fails.

1

1 Answer 1

8

Gmail requires that you have SASL authentication and SLS encryption in order to send mail to it. I spent an ungodly number of hours trying to get this to work when I first started using postfix. OpenSSL was particularly unfun.

http://souptonuts.sourceforge.net/postfix_tutorial.html has a walkthrough of getting all of that configured.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .