0

I'm fairly new to tmux. I tried to google a solution but no luck.

My problem is that after I (sucessfully) split my window vertically for the first time, the second attempt to split the window fails. I see the third pane for a brief second, before it closes. I then can't split it again (it just "bings" when i try). Even if i close the second pane and try to split the only window again, it just "bings". tmux kill-server sometimes help, enabling me to split a new session once. But sometimes i can kill the server multiple times and reboot, and it wont let me split. Horizontal splitting works.

I am using FreeNAS, and using FreeBSD in a jail, that I SSH into. I am using Kitty (putty) for the ssh connection.

Please help, I would really like to get more into FreeBSD/Linux, but unexplainable stuff like that really kills the mood.

  • 1
    What keystrokes are you using? Is it possible you are just opening more tmux tabs? - it might say 0 - bash 1-bash etc. – channon Jul 7 '15 at 15:16
  • I am using Prefix (Ctrl + A in my case) and %. And it works the first time, so I dont know how I could mistake that for opening more tabs. – KittehBit Jul 8 '15 at 7:24
  • try splitting horizontally instead .. the key is " instead of % - Ive seen it be that there is not enough room for tmux to split again. But if you close it, then it should be able to split so this is strange – channon Jul 8 '15 at 14:19
0

This was happening to me. I deleted a .tmux file in my home directory, and that fixed it. You could also try tmux kill-server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.