0

I'm trying to install the amd64 radeon catalyst driver, but it needs kernel headers for 3.7

This is the output of uname -r:

3.16.0-4-amd64

I've already ran apt-get update, apt-cache search linux-headers outputs this

linux-headers-3.16.0-4-common - Common header files for Linux 3.16.0-4
linux-headers-3.16.0-4-amd64 - Header files for Linux 3.16.0-4-amd64
linux-headers-amd64 - Header files for Linux amd64 configuration (meta-package)
linux-headers-3.16.0-4-all - All header files for Linux 3.16 (meta-package)
linux-headers-3.16.0-4-all-amd64 - All header files for Linux 3.16 (meta-package)

It seems like I only have v3.16 on my repositories...

All the help I've found on the internet is for kali, and it won't work on my debian... please help :(

Is there any repository for debian containing linux-headers for 3.7?

If it gives any help, this is my /etc/apt/sources.list

deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 DVD Binary-1 20150425-12:54]/ jessie contrib main

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main contrib
deb-src http://security.debian.org/ jessie/updates main contrib

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ jessie-updates main contrib
deb-src http://ftp.us.debian.org/debian/ jessie-updates main contrib

# firefox
deb http://packages.linuxmint.com debian import

# google chrome
deb http://dl.google.com/linux/chrome/deb/ stable main
  • I ran into this question / answer when I was looking for the headers package for Debian 8. The version that tracks your kernel is "linux-headers-amd64". While that might not help someone looking for 3.7 headers, it will help someone looking for the headers of their running machine. – Brian Bulkowski Feb 6 '16 at 18:17
1

There is no Debian version which uses 3.7 (anymore?).

When you want to compile for the running kernel, you would need the headers for 3.16.

Have you seen https://wiki.debian.org/ATIProprietary?

  • thanks man! that's right. I just ran apt-get install linux-headers-3.16.0.4-all and the installation went neat! just for the record, I downloaded Radeon R6 graphics drivers from here techspot.com/downloads/drivers/essentials/amd-catalyst-linux . Now, the brightness buttons are working "awesomly". – Bengalaa Jul 7 '15 at 15:33
  • Why don't you download it directly from AMD? – Jodka Lemon Jul 7 '15 at 15:54
  • I didn't found it. In fact, I couldn't find "Radeon R6 graphics" on their website... I found several drivers for R*, but none of them was compatible with R6, finally, I found that driver on techspot... I'm glad it worked – Bengalaa Jul 7 '15 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.