0

My nic shows using lspci -v but udev is not loading the driver for it. Links to screenshots of diagnostic output are below.

dmesg

insmod

lspci

pacman -Qi

ls /sys/class/net

uname -a

original thread

More info (manually typed and not copied and pasted from the vm):

find /usr/lib/`uname -r`/kernel -iname "mii*"
/lib/modules/4.0.1-1-ARCH/kernel/drivers/net/mii.ko.gz


modprobe pcnet32
echo $?
1

modprobe -v --dryrun pcnet32
echo $?
1

There was nothing relevant in dmesg after using modprobe. So I tried using insmod on mii and pcnet32. It detected the nics on the machine. So the question now becomes why does modprobe not work?

7
  • Run insmod for pcnet32 and check output of dmesg. There should be cause of insmod failure. Jul 7, 2015 at 12:22
  • see the dmesg and insmod screenshots.
    – sashang
    Jul 7, 2015 at 12:31
  • IMHO you shouldn't use images for posting textual problem. It's difficult for Google (and other search engines) to index problems described by images. However, if you really need posting images, you should upload your images this way. Jul 7, 2015 at 14:28
  • @patryk.beza: it's in a vm. I can't copy and paste from it. Original question was posted on arch forums hence the offsite links.
    – sashang
    Jul 7, 2015 at 14:33
  • You can. Jul 7, 2015 at 14:38

1 Answer 1

0

From insmod manpage:

insmod is a trivial program to insert a module into the kernel. Most users will want to use modprobe(8) instead, which is more clever and can handle module dependencies.

pcnet32 module depends on mii module, which is not loaded when you load pcnet32 using insmod.

modprobe pcnet32 should solve the problem.

Alternatively you can use insmod for mii module and then insmod for pcnet32, but keep in mind that if mii depends on other module, then you will have still similar problem as you posted above.

4
  • no modprobe doesn't help
    – sashang
    Jul 7, 2015 at 14:34
  • Can you post result of the two commands: modprobe pcnet32 and find /lib/modules/`uname -r`/kernel/drivers/net/ -name "mii*"? I reproduced your error and my solution worked for me. Jul 7, 2015 at 14:45
  • update original question.
    – sashang
    Jul 8, 2015 at 0:12
  • OK, now insmod mii && insmod pcnet32 works for you and modprobe pcnet32 doesn't. Post result of: modprobe --dry-run -v pcnet32. Jul 8, 2015 at 15:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .