29

I configured KDE to switch easily from a bépo (french-dvorak) to an azerty layout. I configured it with the KDE interface (systemsettings), but I guess it just call setxkbmap be and setxkbmap fr. The azerty layout is the default (and the first in the list of the layouts).

However, the shortcuts remains attached to the physical keys: pressing the q key yields a "q" in azerty and an "a" with the bepo layout. However, pressing ctrl + q have the same effect in both cases (quitting, in most softwares, for instance with kwrite or konsole). Note however that some softwares (as firefox) do the switch (pressing the j key, which prints a "t" with the bépo layout, and ctrl at the same time, opens a new tab, which is the expected behaviour). According to this comment, GTK apps do the switching, whereas Qt apps do not.

How to make the keys of the shortcuts and the key to enter text coincide in all software

More precisely, the shortcuts are defined according to the first layout in the list. How to make the definition of the shortcuts switch as well for Qt apps?

Configuration (system):

$ kded4 --version
Qt : 4.8.6
Plate-forme de développement de KDE : 4.14.2
Démon de KDE : 4.14.2
$ uname -a
Linux zepto 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.1 (jessie)
Release:        8.1
Codename:       jessie

Configuration (setxkbmap):

$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     fr,fr
variant:    oss,bepo
options:    grp:rwin_toggle
$ localectl list-x11-keymap-variants fr
bepo
bepo_latin9
bre
dvorak
geo
latin9
latin9_nodeadkeys
latin9_sundeadkeys
mac
nodeadkeys
oci
oss
oss_latin9
oss_nodeadkeys
oss_sundeadkeys
sundeadkeys

Related pages :

Edit: This question has been opened 977 days ago, received two bounties, 28 upvotes, has 10 favorites, it is the most upvoted unanswered question as of now, but it wasn't offered one serious motivated answer? I should probably being submitting bug report, but I don't even know what software is responsible!

  • I thought there are layouts that are dvorak + qwerty ctrl (or evivelent for french). There are others that are full dvorak. However I have just tried with french dvorak, and 2 bepo layouts, and can not reproduce this. I am using debian 6 (Wheezy) with kde4. – ctrl-alt-delor Jul 13 '15 at 19:06
  • According to localectl list-x11-keymap-variants us, the only dvorak options available are dvorak dvorak-alt-intl dvorak-classic dvorak-intl dvorak-l dvorak-r. I guess you were referring to softwares as dvorak-qwerty. I edited my question, to provide more details. – Clément Jul 14 '15 at 20:15
  • Any updates on this? – Robert Siemer Sep 19 '16 at 8:03
  • @RobertSiemer Not that I know, unfortunately… There were 2 bounties offered on that question, already, and still no solution… – Clément Sep 19 '16 at 19:42
1

You can set

localectl set-keymap --no-convert <keymap>

Which will change the keymap used at startup. Substitute keymap here with the one you'd like to use. Also ensure that you change your other locale information.

  • Thanks for your answer, Magus, but your answer does not seems to solve my problem. I did localectl set-keymap --no-convert bepo (as a normal user), restarted my computer, but for instance in Kate, pressing the physical keys Ctrl + v always paste my clipobard, no matter my current layout. – Clément Feb 11 '16 at 15:12
  • @Clément localectl sounds like a command to be run as root, how about you try that and let us know? (Likely needs a reboot.) – Ned64 Feb 15 '18 at 10:54
  • @Ned64 No, this command, even executed as root, and even after the reboot, does not solve the problem. – Clément Mar 9 '18 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.