4

There is no sound on my Debian 7. How to set the sound properly now?

root@localhost:/home/debian# alsactl init    
Found hardware: "HDA-Intel" "Realtek ALC887-VD"        "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"      
Hardware is initialized using a generic method   
/usr/share/alsa/init/default:26: control element not found   
/usr/share/alsa/init/default:26: control element not found   
/usr/share/alsa/init/default:48: control element not found   
root@localhost:/home/debian# alsamixer   
cannot load mixer controls: Invalid argument 

EDIT: The output of alsa-info.sh is here.

EDIT 2: After adding the option snd-hda-intel model=generic to /etc/modprobe.d/alsa-base.conf, here's what I get:

root@localhost:/home/debian# alsactl init 
Found hardware: "HDA-Intel" "Realtek ALC887-VD" "HDA:10ec0887,1458a002,00100302" "0x1458" "0xa002"
Hardware is initialized using a generic method
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:26: control element not found
/usr/share/alsa/init/default:48: control element not found
  • 1
    Try this alsa.opensrc.org/TroubleShooting ... have you found any errors using their checks? – Marki555 Jul 8 '15 at 14:06
  • 2
    Have you tried to add options snd-hda-intel model=generic to /etc/modprobe.d/alsa-base.conf? – kirill-a Jul 9 '15 at 14:18
  • Can you pastebin your "/usr/share/alsa/init/default" file content ? – SHW Jul 13 '15 at 9:17
  • 1
    I updated my answer. Please try a more recent kernel. – Jodka Lemon Jul 13 '15 at 9:30
  • Is there any reason for you to avoid pulsaudio? – YoMismo Jul 13 '15 at 9:31
4
+200

Try a newer kernel

You can get 3.16 from backports:

Add the line

deb http://http.debian.net/debian wheezy-backports main

to /etc/apt/sources.list.

Then run

aptitude update
aptitude -t wheezy-backports install linux-image-3.16.0-0.bpo.4-amd64

and reboot.

Debugging ALSA

Get the script

http://www.alsa-project.org/alsa-info.sh

and run it to get information about your soundcard.

When you have more information about your soundcard, create the file

/etc/modprobe.d/mysound.conf

and add the options like this

options snd-hda-intel model=6stack-digout

Especially the model option is crucial, because obviously the generic method does not work.

A full list is in /usr/share/doc/linux-doc-3.2/Documentation/sound/alsa/HD-Audio-Models.txt.gz in the package linux-doc-3.2.

Good luck! Soundproblems can be horrible to debug.

| improve this answer | |
0

Debian 7 "wheezy" was released in may 2013, with a kernel released early 2012. If your sound hardware is more recent than that, it is possible that it just isn't supported by Debian 7.

Have you tried with Debian 8 "Jessie"?

| improve this answer | |
  • no ,my sound card is older than 2010. – showkey Jul 11 '15 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.