0

I have been using debian 8 with KDE 4.14.2 for 2 month with no such issues. Today I was just surfing the internet, and suddenly internet connection disappeared. Ping 8.8.8.8 worked fine, but ping to my router didn't. With my second laptop everything worked perfectly. Both laptops were connected via Ethernet cable. So I restarted PC, and after that I wasn't able to log in using my user&pswd. When I enter them and click login it behaves exactly the same as I would click "turn_off_button -> Restart X Server". What I have tried:

  • gave full permissions to /tmp /var/tmp
  • deleted ~/.authority apt-get install --reinstall kde-full
  • commented out ssh in /etc/X11/xsession.options
  • tried logging in with default | KDE Plasma Workspace | Failsafe
  • X11Forwarding yes is set in /etc/ssh/sshd_config
  • added line "exec startkde" into /etc/X11/xinit/xinitrc
  • video driver is properly installed: "lspci | grep -i vga" gives "00:02.0 VGA compa.......Intel Corp 2nd Gen....(rev 09)"

It may help:

  • here I have only one entry: turn_off_button -> Switch User -> Unused (:0, vt7)
  • I have never logged in as root on this system, always used only one user.
  • cat ~/.xsession-errors:

xrdb: connection refused

xrdb: Can't open display 'localhost:1.0'

xhost: unable to open display "localhost:1.0"

$DISPLAY is not set or cannot connect to the X server.

I have found workaround to this: going to console mode and enter startx. But I want normal logging in. So how to fix this? I spent so much time to setting up my desktop, shortcuts in kmenu, I had problems with wifi, hibernate etc. Don't want to reinstall everything.

0

oh god, after 5 hours of investigation I have found finally a solution. The problem was in the /etc/profile with "export DiSPLAY=..." entry. I removed it, and then kde worked perfectly. I remember I put that line into profile when following some recommendation when wanted to run hnh application about 1 month ago. It is strange that kde stopped running exact today.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.