I have just done a fresh install of Ubuntu 15.04 Server. After I log in, I see the dash and after a while just a black screen with the cursor on it. I have updated my nvidia drivers (sudo apt-get install nvidia-current) but I still have the same problems. I've also removed Unity and tried with Gnome Shell, but none of them work. Any idea on how to proceed?

  • 1
    You should ask your question here
    – A.B.
    Jul 5 '15 at 12:16

if it's a fresh installation that means it still have canonical sources disabled in /etc/apt/sources.list!
try to install xfce4 or lxde , theses light envirments may could work , and then install additional drivers (nvidia recommanded/tested).

sudo apt-get install --no-install-recommends xubuntu-desktop

after you enable canonical repositories in sources.list
lauch additional drivers , install install nvidia (recommanded/tested) , and then you can reinstall again your prefered desktop env !

sudo apt-get install --reinstall  ubuntu-desktop
sudo apt-get install --reinstall kubuntu-desktop
sudo apt-get install --reinstall xubuntu-desktop
sudo apt-get install --reinstall lubuntu-desktop
  • Make sure you reboot to log into the new desktop.
    – ericso
    Mar 14 '16 at 1:42

Remove everything to do with the Nvidia proprietary drivers.

sudo apt-get remove --purge nvidia-*

Start from scratch.

sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall all the things!

sudo apt-get install nvidia-current nvidia-settings
sudo apt-get install xserver-xorg-video-nouveau
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure the X server.

sudo dpkg-reconfigure xserver-xorg

Source, just a little edited.

  • Thanks for your reply! I'm trying it, but it does not find the xserver-xorg-video-nv package. I complete the whole process, but I still get the frozen desktop. Jul 5 '15 at 13:46
  • check this page and try to add ppa. launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers Jul 5 '15 at 13:46
  • I'va added the ppa and it still does not find the package. Also, I've tried some of the suggestions from the other post but I still get no desktop. Jul 5 '15 at 16:13
  • please check this link too, hope be useful. its how to fix on 14.04 but maybe usable at this issue too. sourcedigit.com/… Jul 6 '15 at 11:33
  • No luck. I'm thinking of installing the desktop version and see what happens... Jul 6 '15 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.