0

I got a Raspberry Pi 2 Model B, and I installed on it FreeBSD 11-CURRENT using images provided at ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/arm/armv6/ISO-IMAGES/11.0/

Now I have an USB Wifi dongle with Ralink 5370 chipset, as you can see by usbconfig output:

# usbconfig -d 0.4 dump_device_desc
ugen0.4: <802.11 n WLAN Ralink> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (450mA)

bLength = 0x0012 
bDescriptorType = 0x0001 
bcdUSB = 0x0200 
bDeviceClass = 0x0000  <Probed by interface class>
bDeviceSubClass = 0x0000 
bDeviceProtocol = 0x0000 
bMaxPacketSize0 = 0x0040 
idVendor = 0x148f 
idProduct = 0x5370 
bcdDevice = 0x0101 
iManufacturer = 0x0001  <Ralink>
iProduct = 0x0002  <802.11 n WLAN>
iSerialNumber = 0x0003  <1.0>
bNumConfigurations = 0x0001 

I configured it as follows:

# cat /etc/rc.conf
...
wlans_run0="wlan0"
ifconfig_wlan0="WPA DHCP"

# cat /etc/wpa_supplicant.conf
network={
    ssid="ssid"
    psk="psk"
}

Apparently, driver gets loaded just fine: dmesg says

# dmesg
ugen0.4: <Ralink> at usbus0
run0: <1.0> on usbus0
run0: MAC/BBP RT5390 (rev 0x0502), RF RT5370 (MIMO 1T1R), address 00:22:c0:a2:09:ea
run0: firmware RT3071 ver. 0.33 loaded
wlan0: Ethernet address: xx:xx:xx:xx:xx:xx

and ifconfig states:

# ifconfig
run0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
    ether 00:22:c0:a2:09:ea
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
    status: associated
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 00:22:c0:a2:09:ea
    groups: wlan 
    ssid "" channel 8 (2447 MHz 11g)
    country US authmode WPA1+WPA2/802.11i privacy MIXED deftxkey UNDEF
    txpower 0 bmiss 7 scanvalid 60 protmode CTS wme roaming MANUAL
    bintval 0
    media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
    status: no carrier
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>

Still,

# ifconfig wlan0 up list scan

returns an empty output. The same adapter, connected to my main computer with Debian, correcly lists my network, as it did on the raspberry itself with default raspbian installed.

Another strange thing (but probably unrelated, given the dongle is usb) is:

# pciconf -vl
pciconf: /dev/pci: No such file or directory

UPDATE: seems like it is a power issue, as my phone hotspot, which is nearer, gets recognized. However, the fact that with raspbian it was fine means that the linux driver for the adapter was able to detect more networks with the same amount of power, or that it was able to provide more power (despite getting power from the very same port)

0

I mitigated the issue switching my wireless router to channel 1. Lower frequency traverses walls more easily, and now the Pi manages to connect. It is not an actual solution, but may help someone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.