10

I have Virtualbox in my Linux Mint box, my Virtualbox is always running, so when I want to change my applications using Alt+Tab I'm always redirected to my Virtualbox window, because it's always in my Task List.

I want to know how can I skip a window or program from Alt+Tab paging. It`s possible in MATE or Unity by twiddling with Compiz, but I want to know how can I remove my Virtualbox task from the Alt+Tab list in Cinnamon.

I have the virtualbox applet in my system tray, so I'd like to hide the window, i.e. remove it from the task bar.

Is there any method to remove a window from the Alt+Tab task list, or remove a window from the task bar in Cinnamon?

  • 1
    You can draw that window to another virtual desktop, this way it does not show up with alt+tab. – Soprano Jul 17 '15 at 9:56
1

This answer doesn't have anything to do with hiding things from Cinnamon specifically, but it helps those with this specific problem.

I suggest using the "Headless Start" feature of VirtualBox. In the VirtualBox Manager, instead of just clicking Start to start your VM, right click the VM instead and choose Start -> Headless Start.

Your VM starts in the background, with no window, and therefore nothing on the taskbar, staying out of the way until you need it.

When you need it, select it in the VirtualBox Manager, and a Show button will appear in place of the usual Start. Clicking Show opens your VM in a window for you to interact with it as you will.

To send it back to the background, Perform File -> Close on the VM's menu and choose "Continue running in the background." Poof, gone again until you need it.

As I understand it, "Headless" has been available for some time with external tools, but was later added to the GUI VirtualBox Manager. Tested in VirtualBox 5.0.2 under Linux Mint 17.2 host; I have three headless virtual machines running as I type this.

0

Right Ctrl + Alt + Tab to go back to the host OS.

0

VirtualBox automatically captures keyboard input to give a smoother experience. So when you press alt + tab it shifts to VirtualBox and then the next alt + tab will happen within the VM.

Here is your solution (Source):

VirtualBox has a checkbox called "Auto Capture Keyboard"
(> File > Preferences > Input). Turn it off.

Now you will have to click inside the VM for it to capture keyboard inputs.

0

I think perhaps avoiding Alt+Tab is a good idea. Cinnamon has hot corners - I have my corners set to present my windows as a grid of icons (Show All Windows) which is like 'Scale Windows' in Compiz, enabling me to direcly click the window I want next.

For a keyboard cowboy (as you prefer ALT+TAB I guess this is you...) I'd recommend CTRL+ALT+UP and CTRL+ALT+DOWN - scale windows, and the same but with workspaces (Show all workspaces also scales all the windows in each workspace).

If you're just using one workspace, you can delete all the others and just use CTRL+ALT+DOWN.

Using the 'Keyboard' app, you can easily reset this shortcut - CTRL+~ should do the trick, just one key up from tab.

This answer works for me, as I have no idea how to set window rules in Cinnamon - it's not available through the common tools. It works for conky (skip pager) but the window manager is a little more tightly wired in favour of stability than was Compiz.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.