3

The target embedded Linux is ARM Xilinx Zynq, and I am working in CentOS to compile to ARM using Xilinx's tool. The target OS is working now and I want to setup the wifi using iwconfig.

I downloaded wireless tool from hp using git, and tried to cross compile it by modifying the Makefile to use the cross compiler

cc = arm-xilinx-linux-gnueabi-gcc

And it seems working since I can run iwconfig after copied everything to the target. I can turn on the usb wifi now (ASUS USB-N13, rtl8192cufw_TMSC.bin is copied to /lib/firmware/rtlwifi). I had to manually copy the .so files into the /lib directory on the target to let it run. However, when I run further tools, an error shows up saying

can't find /proc/net/wireless

I know this is a virtual file, so what should I do to let it work? I know if I install the iwconfig it will complete everything. So do I need gcc to run on the target ARM to install it, or can I cross compile it on CentOS and make the changes to the target build, to be included in the kernel image file?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.