2

I'm using x64 Ubuntu. A few months ago I accidentally messed up the groups/owners of all files on /, but managed to fix it using a VirtualBox install of Ubuntu.

Now I'm running into a problem that I think is related to that mistake. When I try to reinstall ia32-libs (Skype is having problems so I need to reinstall those libs) I get an error message:

/var/lib/dpkg/info/ia32-libs.postinst: 40: /usr/lib32/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders: Permission denied

ls -al /usr/lib32/gdk-pixbuf-2.0/` is this:

total 476
drwxr-xr-x  3 root root   4096 2011-09-24 17:08 .
drwxr-xr-x 53 root root 143360 2011-09-24 17:08 ..
drwxr-xr-x  3 root root     40 2011-09-24 04:44 2.10.0
-rwxr-xr-x  1 root root   9648 2011-04-05 00:40 gdk-pixbuf-query-loaders

I have tried to reinstall gdk-pixbuff-2.0, but it didn't work. How can I fix this?

1

Run ldd /usr/lib32/gdk-pixbuf-2.0//gdk-pixbuf-query-loaders and make sure every file is accounted for (the line must end with an address like (0xf7789000)). In particular, check the permissions on the dynamic loader /lib/ld-linux.so.2. This is the only file in the lot that could cause that particular error message, but you may need to fix other permissions while you're at it.

chown root:root /lib*/*
chmod a+rx /lib*/ld-* /lib*/*/
chmod -R a+r /lib
  • AAA IT WORKED! :) When i run "ldd" first time (as su or normal user) command i get result "not a dynamic executable" but then i performed those "chown" commands you specified and then "ldd" worked as a charm AND ia32-libs GOT RE INSTALLED WITHOUT ERROR! :) THENK YOU KIND SIR :) – BoPe Sep 25 '11 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.