1

I am editing syslog and want to log ppp to a log. I added the last two lines to do so, as recommended in the ppp configuration. It appears to log ppp but also other things, due to the * I guess. I also get the error in the title. Any idea what the logging lines should be?

# /etc/syslog.conf - Configuration file for syslogd

auth,authpriv.*     /var/log/auth.log
*.*;auth,authpriv.none  /var/log/messages
user.*          /var/log/user.log
local0.*        /var/log/switch.log
local1.*        /var/log/audit.log
*.emerg         *
local0.*        /dev/ttyS0
!ppp
*.*             /var/log/switch.log
2

to make it short, syslog.conf is configured like this

 facility.priority /place/to/log

ppp's facility is daemon. priority range from debug to panic.

your last line

 *.* /var/log/switch.log

will log any facility on any priority to switch.log. This likely result in a flood.

Try

  daemon.debug /var/log/daemon.log

note also that according to pppd(8) (man page for pppd), pppd can be told to log to specific file.

Edit:

  1. you have to guess what is the facility, I did it more or less for HPUX logging ftp connection .

  2. two or more programs can share the same facility, some post processing (e.g. grep ppp) on log file is required.

|improve this answer|||||
  • Thanks, i will try your answer, I had tried mine as I had seen it several places online even though it didn't make sense to me freebsd.org/doc/en_US.ISO8859-1/books/faq/ppp.html Will try similar for the chat program. – Paul Jul 2 '15 at 10:36
  • How do you know what facility something has? I am trying to find chats one. also if I use daemon for ppp it will log things like mstpd as well. – Paul Jul 2 '15 at 10:44
  • I read in a book to use local2.debug for chat and it does work, however I have no idea why or how I would find this information otherwise, very strange. Thanks for the help – Paul Jul 2 '15 at 10:58
1

I was getting this error when using logger command from bash and incorrectly using the '-p' flag. See its man page under 'FACILITIES AND LEVELS' for all allowed values. My working command looks like:

logger -p cron.info -t "($0)[$$]" "I'm going to the cron log."
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.