0

1) I installed chromium beta v44 on linux mint 17 (rebecca) as per discussion here:

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1371274

sudo add-apt-repository ppa:saiarcot895/chromium-dev
sudo apt-get update
sudo apt-get install chromium-browser

2) I copied libwidevinecdm.so and libwidevinecdmadapter.so into /usr/lib/chromium-browser/ folder. I retrieved these libraries from the tar file below which was posted as an attachment to bug 1371274.

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1371274

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1371274/+attachment/4397708/+files/WidevineLinuxForChromium44.tar.gz

3) I see the following library when I go to chrome://plugins

Widevine Content Decryption Module
Enables Widevine licenses for playback of HTML audio/video content.

4) If I try to view a netflix film I get the redirects error:

Netflix - Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

5) HOWEVER, if I change the user-agent

from:

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/44.0.2403.30 Chrome/44.0.2403.30 Safari/537.36

To (tricking netflix to think browser is google chrome):

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.30 Safari/537.36

I don't get the re-directs error but instead netflix throws back the following missing components error:

We cannot find all the required components to play Netflix on this device. Please visit chrome://components, locate the WidewineCdm component, and click the "Check for update" button.

If I go to chrome://components I do NOT see the WidewineCdm component there although I do see it in chrome://plugins.

Any idea how to get this working - either without modifying the user-agent or after modifying it?

UPDATE

Output of ldd /usr/lib/chromium-browser libwidevine*

/usr/lib/chromium-browser:
ldd: /usr/lib/chromium-browser: not regular file
libwidevinecdmadapter.so:
    linux-vdso.so.1 =>  (0x00007fffd45fe000)
    libwidevinecdm.so => /home/bean/Downloads/./libwidevinecdm.so (0x00007f167c164000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f167be41000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f167bc22000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f167b85d000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f167b557000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f167b340000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f167c902000)
libwidevinecdm.so:
    linux-vdso.so.1 =>  (0x00007ffff65fe000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff82d878000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff82d574000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff82d35d000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff82d13f000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff82cd7a000)
    /lib64/ld-linux-x86-64.so.2 (0x00007ff82e326000)
  • anyone here know who I can contact to get help? – codingknob Jul 3 '15 at 3:00
  • Can you try downloading Chrome Dev (version 45) and copying the binaries from there? – saiarcot895 Jul 3 '15 at 3:32
  • I tried to remove the beta Chromium (v44) so I can install the Chrome Dev (v45) you suggested but I can't ppa-purge it. See unix.stackexchange.com/questions/213818/… – codingknob Jul 3 '15 at 22:02
  • Ah, I thought you were using chromium-dev instead of chromium-beta. In that case, Widevine should have worked. – saiarcot895 Jul 3 '15 at 22:24
  • was using chromium-beta v44. Not working. Next steps? – codingknob Jul 3 '15 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.