3

I am running Linux Mint 17.1 with Cinnamon. Every time I launch emacs24, either from a command line or from a launcher, it sizes itself to just less than the full size of the screen. --geometry has no effect; a setting in .Xresources has no effect. Shortly after starting, it generally hiccups and fiddles with the size again.

Is there any way to stop this? I just want about 1/2-of a screen of emacs.

I tried:

emacs24 --geometry 80x24

and, in .Xresources:

Emacs*geometry: 80x24

and I tried:

emacs -q --no-site-file

none of these changed the behavior.

I ran the precise command:

/usr/bin/emacs24 -q --no-site-file --geometry 80x24

and I still got an expanded Window. I suspect some sort of cinnamon auto-expansion, but I can't find any relevant setting.

The current version of cinnamon on Mint 17.1 is:

Cinnamon 2.4.8
  • Please edit your question and show the exact command (--geometry) and .Xresources setting that didn't fail so we don't reinvent the wheel. – terdon Jul 1 '15 at 11:53
  • Run emacs with -q --no-site-file - if that works, then you have a setting in your personal or system initialisations. At which point, try just -u, of course. – Toby Speight Jul 1 '15 at 12:03
  • Odd. I can't reproduce this on Cinnamon 2.6.7 on Debian. Running ` emacs24 --geometry 80x24` gives me an 80x24 window. Does it work if you run /usr/bin/emacs24 -q --no-site-file --geometry 80x24? Please run that exact command. – terdon Jul 1 '15 at 13:08
  • @terdon I did that. – bmargulies Jul 1 '15 at 14:54
  • What version of cinnamon is this? (Run cinnamon --version to check). Since I don't have it, you might want to try upgrading it. – terdon Jul 1 '15 at 14:57
2

It might still be emacs setting the window size. In my ~/.emacs I have this line:

(add-to-list 'default-frame-alist (cons 'height 43)) ;better window size

I probably picked that value through experimentation. That gives me a frame that is 43 text lines long, including the mode line and the echo area but not the menu bar (which I have disabled).

The number of lines, along with the font size (defined in (custom-set-faces in my ~/.gnu-emacs-custom) should define the window size. Mine includes :height 98.

1
+50

With Cinnamon 3.2.7, the geometry value is not ignored completely. For example, when setting a 10x10 geometry I get 60 columns and 38 rows. While not perfect, is good enough to be able to get a non maximized window.

For .Xresources, I needed to change the syntax a little:

emacs.geometry:10x10

I wonder if the geometry is being affected by some kind of environment variable used for a 4K display. But looking to env I do not find anything interesting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.