I wander how to disable event sounds in kde5 Plasma (the one that is heard when scrolling the volume in systray for example).

I use Plasma in Opensuse 13.2 but this is KDE specific methinks.


These are the available settings (after answer):

enter image description here

enter image description here

5 Answers 5


In recent Plasma 5, search "Audio Volume" in the application launcher and, under 'Applications' tab, disable 'Notification Sounds'.

enter image description here

In some Plasma versions the above doesn't work, as I now see in Kubuntu 17.10. The Audio Volume tool looks different and notifications sounds is already muted.

enter image description here

To stop the volume scrolling sound etc in this case, I have unmuted, and moved the slider to zero, and muted again. Something is buggy here though, as the slider is in fact always stuck to zero, and only the mute/unmute button does the work.

In this case I have noticed that a different tool can be used: pavucontrol-qt:

enter image description here

After using this, the bug mentioned (slider stuck to zero in "Audio Volume") disappeared.

  • 2
    Setting it to 0% had no effect for me. but pressing the mute button did. Commented Aug 4, 2017 at 12:24
  • @ctrl-alt-delor - only now I've got your point, seeing the same occurrence in Kubuntu. Edited my answer.
    – user32012
    Commented Feb 5, 2018 at 9:15
  • Just muting notification sounds didn't help me. The slider became grey, but the volume level was ca. 70% and the notification sounds were still active. I also had to set the volume level to 0%. This is somehow counter-intuitive. Must be a bug.
    – ka3ak
    Commented Jan 10, 2020 at 18:07
  • 1
    I used pavucontrol-qt to set volume > 0 since it was stuck also in main control but the the program I am using, Hexchat, is still not making any sounds. Commented Apr 14, 2020 at 20:41
  • The slider is bugged: shows that it's muted, but it's not.
    – Velkan
    Commented Apr 25, 2022 at 7:37

On KDE Plasma 5.22, Open System Settings, navigate on the menus to this place: Application Settings window and click the "Configure Events" button. This window will popup: Configure Notifications window here you can disable/change the system sounds on an individual basis.

  • the best answer!
    – evb
    Commented Feb 26, 2022 at 12:19
  • But how to do it in one click? alternative for "No Sounds" theme in Windows, we have to visit each possible app and check if any event has sound notification enabled.
    – Maxim
    Commented Aug 13, 2023 at 16:20

in kde5, as root:

cd /usr/share
mv sounds sounds.backup
  • bad idea, you damage sound files itself, not force options for notifications
    – Maxim
    Commented Aug 13, 2023 at 16:21

It's very annoying, isn't it? I haven't found a way to disable it but muting it is easy. Fire up kmix, scroll down "Event Sounds" to the bottom. Job done.

  • Very odd, but I cannot find that. Kmix (version 4.6RC1) contains but 4 tabs: Playback Devices, Capture Devices, Playback Streams and Capture Streams. I see no Event Sounds anywhere.
    – user32012
    Commented Jul 6, 2015 at 14:16
  • This works for me. The Event Sounds slider is in the Playback Streams tab. Commented Mar 16, 2023 at 23:44

I think I've been able to resolve this by switching to the Gstreamer audio backend instead of VLC. Once I switched backends, Kmix showed a new "PCM" slider which seems to affect notification sounds.

  • Well, this seems half correct now that I've had it set for a while. PCM does affect notification sounds, but that includes ALL notification sounds regardless of app; so now I can't hear my Pidgin chat alerts.
    – danarchy85
    Commented Jun 17, 2016 at 2:46

You must log in to answer this question.