1

for FREAK vulnerability,

I tried to Upgrade Apache 2.4.12 from 2.4.10 and OpenSSL to 1.0.2c using following line

./config  --openssldir=/usr/local/openssl
 make
 make test
 make install

enter image description here

Once OpenSSL upgraded successfully. I tried to upgrade apache2.4.12 by manually using following line.

 ./configure --prefix=$apache_install_path --with-included-apr=$PACKAGE_PATH/$APACHE_INSTALLATION_PKGNAME/httpd-2.4.12/srclib/apr --with-pcre=$PACKAGE_PATH/$APACHE_INSTALLATION_PKGNAME/pcre-8.36/pcre-config --with-included-apr-util=$PACKAGE_PATH/$APACHE_INSTALLATION_PKGNAME/httpd-2.4.12/srclib/apr-util --enable-mods-shared=all --enable-ssl=shared --enable-ssl  --enable-rewrite=shared --enable-proxy=shared --enable-headers=shared --enable-expires=shared --enable-cern-meta=shared --enable-unique-id=shared --enable-mime-magic=shared --with-ssl=/usr/local/ssl --enable-so --enable-module=so --enable-module=rewrite --enable-shared=rewrite --enable-load-all-modules $@ >> "${HTTPD_LOG}" 2>&1

Assume APR,APR-Util and Pcre already complied and installed.

We are getting following errors in httpd compile log.

Making install in ssl
make[2]: Entering directory `/data/AMOS/PACKAGES/Apache/Apache2.4.12_installation_packages/httpd-2.4.12/modules/ssl'
make[3]: Entering directory `/data/AMOS/PACKAGES/Apache/Apache2.4.12_installation_packages/httpd-2.4.12/modules/ssl'
/usr/local/apr/build-1/libtool --silent --mode=link gcc -std=gnu99 -I/usr/local/ssl/include   -g -O2 -pthread    -L/usr/local/ssl/lib   -lssl -lcrypto -lrt -lcrypt -lpthread       -o mod_ssl.la -rpath /usr/local/apache2/modules -module -avoid-version  mod_ssl.lo ssl_engine_config.lo ssl_engine_init.lo ssl_engine_io.lo ssl_engine_kernel.lo ssl_engine_log.lo ssl_engine_mutex.lo ssl_engine_pphrase.lo ssl_engine_rand.lo ssl_engine_vars.lo ssl_scache.lo ssl_util_stapling.lo ssl_util.lo ssl_util_ssl.lo ssl_engine_ocsp.lo ssl_util_ocsp.lo  -export-symbols-regex ssl_module
/usr/bin/ld: /usr/local/ssl/lib/libssl.a(s3_srvr.o): relocation R_X86_64_32 against `.rodata' can not be used when making a shared object; recompile with -fPIC
/usr/local/ssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [mod_ssl.la] Error 1
make[3]: Leaving directory `/data/AMOS/PACKAGES/Apache/Apache2.4.12_installation_packages/httpd-2.4.12/modules/ssl'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/data/AMOS/PACKAGES/Apache/Apache2.4.12_installation_packages/httpd-2.4.12/modules/ssl'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/data/AMOS/PACKAGES/Apache/Apache2.4.12_installation_packages/httpd-2.4.12/modules'
make: *** [install-recursive] Error 1
  • "Upgrade Apache 2.4.10 from 2.4.12". Do you mean downgrade? – Jérôme Jul 1 '15 at 7:31
  • Updated. Can you answer my question? – ashokhein Jul 1 '15 at 12:41
  • 1
    It says to recompile with option -fPIC did you try that ? – Pierre-Alain TORET Dec 24 '15 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.