0

Have a new secondhand PC, running Linux Mint 17.1 Cinnamon 64 Bit, Linux Kernel: 3.13.0-37-generic. System info recognises two VGA cards - onboard and the GTX 770.

However, when I query

lscpi -vnn | grep VGA -A 12

The response I get is:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device [1043:8465]
Flags: bus master, fast devsel, latency 0, IRQ 50
Memory at da000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=128M]
Memory at d8000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
[virtual] Expansion ROM at db000000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel driver in use: nvidia

However this graphics card is supposed to have 2GB GDDR5 as far as I'm aware.

0

I am wondering if you are running your card with nouveau(open source drivers) or nvidia drivers? I guess you are running on open source!

You should try to install the proprietary drivers (nvidia drivers) to see if it is really reading your card wrong. With nvidia-setting you should be able to see everything related to your GPU.

This site should show you how to install them easily mintguide.org.


(source: tomshardware.com)

image source : tomshardware.com

This is an old image but you should see the right information!

Keep me posted !

  • Hey :) Thanks for response. nvidia settings is reading the correct memory I have been working converting extremely large bitmaps to vectors so I believe that I'm just experiencing the limit of my hardware, guess i'll just wait till i can upgrade :) – Kennedy Jul 1 '15 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.