1

Summary:

  1. OS (Ubuntu / Windows) installs fine, but when the time comes to restart and boot, it doesn't boot. (Gets stuck; screen blinks and I am still at boot selector).
  2. Can boot to a live CD (USB). In fact, typing on a live UBUNTU.

I had a nice running Windows 8.1 operating system when I made the unfortunate decision to install fedora linux. I shrinked one of my Drive (not windows drive), and got some unallocated space for linux installation. And then I installed Fedora linux on that space which went fine. It created a boot selector so that I could either select windows 8 or Linux. However, when I chose win 8 it won't boot. I would throw out: "No boot record found" type of error. I tried to mess around with grub2 and made it discover windows installation and create config file. It seem to do that well (said: found windows), but then when I try to boot it doesn't work. Fed up, I tried installing windows 10 on the save drive as windows 8 (after formatting it). The installation went fine, but come the time to restart and boot win 10 to finalize installation it won't boot. I don't even see any error message this time. I then tried to install Ubuntu on a cleanly formatted drive. (formated and deleted all drives except for two non-os document drives). Same problem again, I see ubuntu listed in boot selector but it won't boot. The screen blinks but I get stuck there. I am currently on a live Ubuntu (on a flash drive). Here is the output from my fdisk -l:

    Disk /dev/loop0: 1 GiB, 1101672448 bytes, 2151704 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 3E945676-78B0-47D0-9571-8F4CEC2284DB

Device         Start       End   Sectors   Size Type
/dev/sda1   10917888 342949887 332032000 158.3G Linux filesystem
/dev/sda2       2048  10917887  10915840   5.2G EFI System
/dev/sda3  811796480 976771071 164974592  78.7G Linux swap
/dev/sda5  342949888 547749887 204800000  97.7G Microsoft basic data
/dev/sda6  547749888 714139647 166389760  79.3G Microsoft basic data

Partition table entries are not in disk order.
Disk /dev/sdb: 14.9 GiB, 16013942784 bytes, 31277232 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: CBC5B879-137D-42AD-A281-8A2867C17E98


Disk /dev/sdc: 14.9 GiB, 16013942784 bytes, 31277232 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D52F7855-B79B-4A1B-8CEB-F04BA24F7BCF

Device     Start      End  Sectors  Size Type
/dev/sdc1   2048 31277198 31275151 14.9G Microsoft basic data

I just want 'a' OS now. Any help would be much appreciated.

Thanks.

  • When you boot, highlight the entry that you want to boot, and click e to edit. Add acpi=off option. Just like show here – Sergiy Kolodyazhnyy Jun 30 '15 at 20:46
  • @Serg Thanks for your comment. Unfortunately, I am not even getting to the grub bootloader. Its just a choice provided by my BIOS, (Ubuntu, hd0, usb0). I choose Ubuntu (or hd0) and nothing happens. – rajendra Jun 30 '15 at 20:59
  • OK, I'm no UEFI/BIOS or Windows 8 expert, but frequently I can see on other questions when people install another os along side windows 8, there's often issues arising from the "Secure Boot" setting. Can you poke around your bios and see if there's something like that ? Try disabling that and reboot. – Sergiy Kolodyazhnyy Jun 30 '15 at 21:09
  • Also, can you add some information about the machine you've installed it on ? Model , perhaps BIOS version – Sergiy Kolodyazhnyy Jun 30 '15 at 21:17
0

I'm reposting Part of Another Answer here in hopes that it will help you, instead of telling you to use a VM... If doing this helps, I'll readd Part 2 with some explanation that fits here. BTW, these screenshots are from my Personal Laptop, that I used this method with to keep Windows Update from bonking my non-refind EFI, discussed in the question I asked recently below, after which I replaced Ubuntu with Mint 17.1 Rebecca.


Replace the Windows UEFI Bootloader

  1. Download Refind, and see the question I asked recently dealing with some of the issues you'll face.
  2. Assuming you're using Windows 8.1, you'll want to use the Refind CD-R Image. Be sure to extract the ISO from the zip file, and mount it in Windows 8.1. Note: You need not burn the image as Windows 8.1 supports mounting ISO files now like Linux has for years. If you choose not to extract it from the zip file, double clicking the ISO from the zip file will mount it while zipped. Step 1
    Double Click this file. If any helper application appears click OK to accept the defaults. I had no helper application because Windows 8 can now natively mount ISO files
  3. Notice the newly mounted file (Your Drive Letter may be different): Mounted ISO as Drive E
  4. You should now be able to follow the directions outlined in the Installing rEFInd Manually Using Windows from the Administrative Command Prompt. I've marked the directory used in the xcopy command: Directory Listing of Mounted ISO The /s option mounts the EFI/ESP Drive.
  5. Reboot the machine. You should see an image similar to this:
    Refind Boot Manager Please note that the Linux options may not exist in your screen because you will not have them installed properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.