I can't boot because of some strange error. There is an error report file generated for me, to supposedly submit it along with a bug report, or whatever. So to help me figure out what the problem is, it would help to save that error report file. But to do that, I must mount a storage device. However, in order to do that, I need the vfat module. To import that, I need to... I don't know what I need anymore, I'm running in circles here and I have not even begun to tackle the main problem.

I tried mounting my UFD, which is FAT32 formatted. So that didn't work. Mount command doesn't understand the filesystem. Can I save it over the local network? How do I do that? Is there another way?

The shell I am at is the Dracut Emergency Shell of Fedora 22. I understand it is a very limited shell. So what can I do to get that file?


The file is stored at /run/initramfs/rdsosreport.txt

I may point out that I am able to boot into Fedora in recovery mode, as well as normal mode (if I go the extra mile and swap around some hard disk drives). But I am curious to see what can be done from this so called "emergency mode"? To begin with, it seems reasonable enough to me, that one should be able to copy that report file. It even tells me to do so! So how do I do it then, with a limited shell and not a lot of commands available?

  • I do have the mount command, cp, mkdir, ls and so on. But what good are they if you can't mount a filesystem? What if I format the UFD with ext3 or ext4? Or another filesystem that's native or well supported by Linux? On that note, mkfs is missing.
    – Samir
    Jun 28 '15 at 0:26

I didn't bother researching how to import missing modules and such. That's a pretty steep learning curve for my taste, as I am only starting to use GNU/Linux. Instead, I formatted the UFD with ext4 using a healthy Ubuntu installation on another PC. I was then able to mount it on the patient PC, and from there I only had to copy the file.

In terminal on the healthy PC:

umount /media/username/banana
mkfs.ext4 /dev/sdc1 -L cherry

Make sure to unmount the storage device before formatting. On Ubuntu, USB devices are usually mounted under the media directory by default. Give the new volume a friendly name for easier identification. The device node name may be different on your system.

In the emergency shell on the patient PC:

mkdir -p /mnt/cherry
mount /dev/sdc1 /mnt/cherry
cp /run/initramfs/rdsosreport.txt /mnt/cherry
umount /mnt/cherry

This worked for me. Your mileage may vary. I did not have access to Linux commands like rcp or scp. If I am not mistaken it would have been hard to copy the file over a local network, e.g. to my Ubuntu PC. I had 171 commands available, shell commands that is.

If someone knows a way to use these shell commands to copy the file over a network cable, or how to import the missing vfat module and mount a FAT32 volume so I can save it to that, feel free to post an answer and I will accept that as a solution if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.