2

I've tried to make my Raspberry Pi into a print/scan server today. The CUPS print server install & config ran fine and everything works, however I'm not able to get SANE scan server to work.

I'm using the hplip library from the raspbian repo

When running a scan program (eg. scanimage) it fails with an error

scanimage: open of device hpaio:/net/HP_Color_LaserJet_CM1312nfi_MFP?zc=NPI156760 failed: Error during device I/O

When examining the syslog, I found the following:

Jun 27 18:20:21 raspberrypi scanimage: scan/sane/soapht.c 90: 
  unable to load restricted library /usr/share/hplip/scan/plugins/bb_soapht.so:
  /usr/share/hplip/scan/plugins/bb_soapht.so:
  cannot open shared object file: No such file or directory

It looks like the required library is missing, however upon examining the directory:

pi@raspberrypi ~ $ ll /usr/share/hplip/scan/plugins/
total 184
lrwxrwxrwx 1 root root    50 Jun 27 18:02 bb_marvell.so -> /usr/share/hplip/scan/plugins/bb_marvell-x86_32.so
-rwxr-xr-- 1 root root 34191 Jun 27 18:02 bb_marvell-x86_32.so
lrwxrwxrwx 1 root root    49 Jun 27 18:02 bb_soapht.so -> /usr/share/hplip/scan/plugins/bb_soapht-x86_32.so
-rwxr-xr-- 1 root root 53985 Jun 27 18:02 bb_soapht-x86_32.so
lrwxrwxrwx 1 root root    47 Jun 27 18:02 bb_soap.so -> /usr/share/hplip/scan/plugins/bb_soap-x86_32.so
-rwxr-xr-- 1 root root 17552 Jun 27 18:02 bb_soap-x86_32.so
-rw-r----- 1 root root 13019 Jun 27 18:08 hp-check.log

The file in question exists.

I tried reinstalling the hplip library from the website, instead of the repo, however I'm getting errors such as:

configure: error: "cannot find libjpeg support"

When trying to install all of the required dependencies as people suggested while troubleshooting this, I get a lot of missing packages:

E: Unable to locate package libcups2-dev
E: Unable to locate package libcupsimage2-dev
E: Package 'libdbus-1-dev' has no installation candidate
E: Package 'ghostscript-x' has no installation candidate
E: Unable to locate package libssl-dev
E: Unable to locate package libjpeg8-dev
...

I spent the past few hours trying to fix this to no avail

EDIT: Also, when running hp-check, it displays a lot of missing packages (probably the ones missing above).

2

The scan plugin exists but isn't appropriate for a Raspberry Pi (which isn't x86 but ARM). If HP don't provide an ARM-compatible plugin for your scanner then I'm afraid you won't be able to get it to work on your Pi...

  • Completely missed that, looks like I'll have to find a different use for the raspi. Thanks! – Vultour Jun 30 '15 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.