1

I have currently installed Debian in my system alongside Windows 8.1. I have a problem in mounting my other partitions in debian. When trying to open it the following error pops up:

Error mounting /dev/sda5 at /media/amit/New Volume: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda5" "/media/amit/New Volume"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda5': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

I could however mount the partitions read only from the terminal

  • Isn't the error message quite clear? – Basile Starynkevitch Jun 26 '15 at 16:53
  • @BasileStarynkevitch I did shutdown my windows completely but the error still pertains. Is there something else that I should do? – Amit Raj Jun 26 '15 at 16:59
  • I never used Windows so cannot help. But did you consider to use Ext3 file system on your shared disk. There are some Ext3 drivers for Windows, and it is very common on Linux. – Basile Starynkevitch Jun 26 '15 at 17:01
  • I will certainly look at that. Anyways thanks for your time :) – Amit Raj Jun 26 '15 at 17:04
  • Is there any way to run a chkdsk (or other fsck equivalent) under Windows? – Basile Starynkevitch Jun 26 '15 at 17:08
3

As I commented, the (NTFS) file system was dirty, as the error message was saying.

So checking it (on Windows) with a chkdsk command (or the Windows equivalent of fsck) -to clean it- then rebooting Linux could be enough.

If you absolutely need Windows with some data shared with Linux, you could consider using an Ext4 (or Ext3) file system (shared with Linux) on Windows, perhaps using (on Windows) ext2fsd

2

Further to Basile's answer, once you are able to successfully mount the ntfs partition you may need a driver such as ntfs-3g in order to be able to write/copy data from it.

  • Thanks for that bit :) i already have it in the system but didn't know that it was the reason I could write/copy from the ntfs partition. – Amit Raj Jun 26 '15 at 18:19
  • No problem, it caught me out on a fresh Arch install where I could mount and read but not write any data on an ntfs drive. – hrothgar Jun 26 '15 at 18:20
1

Like the error message notes, it's often caused by Windows's Hybrid Boot(tm) aka fast startup. It's sort of midway between hibernation and normal shutdown and often leaves drives dirty. Disable it if you run into this problem again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.