3

Terminator is my choice of terminal in debian. I seem to have broken it while playing with its profile preferences.

I can't open it normally as other applications. However after becoming root I can access it through gnome-terminal. When it opens, the following warning pops up:

An error occurred while loading or saving configuration information for terminator. Some of your configuration settings may not work properly.

Details :

No D-BUS daemon running

5

Have you tried purging the package and then reinstalling it?

apt-get purge terminator

Then delete configuration files located in your home directory

rm -rfvI /home/your_user_name/.config/terminator

This should remove all the config files. Now reinstall.

apt-get install terminator
  • Yes I did. But the problem prevails!! – Amit Raj Jun 26 '15 at 14:44
  • Do you have the ~/.config/terminator/config file? If so you might have to manually delete it. – 111--- Jun 26 '15 at 14:46
  • Yes did it, but still not working. – Amit Raj Jun 26 '15 at 14:50
  • Ok so just to make sure, you purged the package with apt-get purge terminator then deleted all config files from your user's directory (not root's home directory by accident). I suggest specifying your user's home directory rather than using ~ like rm -rfvI /home/your_user_name/.config/terminator. Then reinstall terminator. If this does not do the trick then I'm stumped. – 111--- Jun 26 '15 at 14:55
  • I had deleted the config files from the root directory. Sorry, my bad!! Problem solved :D thanks to you :) – Amit Raj Jun 26 '15 at 15:02
1

Instead of removing entire Terminator, just purge its configuration file and restart. This hack work for me

sudo rm ~/.config/terminator/* -rfv
0

I didn't face this issue in ubuntu normal flavor, but with ubuntu-gnome, I had to install python-psutil to run it.

sudo apt-get install python-psutil

and then try opening terminator

0

Instead of purging entire Terminator, just purge its configuration file and restart. It will work for sure.

sudo rm ~/.config/terminator/config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.