5

A week or so ago, triggered by I don't know what (but presumably something I did by accident) the Notification Area of my taskbar has become 3 times the size that it needs to be, taking up valuable space from the Window List. See attached screengrab with some scrawled notes on it.

I can't seem to get it to take up less space. As you can see, it's mostly just empty grey.

Am I a complete doofus? (I'd much rather be asking some obscure question about some command line operation). Any suggestions welcome.

my toolbar

EDIT - some further notes

  • if I right-click on the drag handle, I can see that it is NOT locked. I have the option to move it, which moves the whole Notification Area, remove it or lock it.
  • right-clicking on the large grey expanse does nothing.
  • if I drag the drag handle over to the right (hoping this would move the divider), then the whole Notification Area, including the grey expanse, moves to the right of the clock.

EDIT - I just removed it from the taskbar and then added it again, and it's gone back to normal. I'd swear i tried that already. So, I'm now uncertain what to do with this question, which has now gone into "unreproducible by myself, aka 'one of those things'" territory. I'll leave it up since if someone can come along and tell me what caused the bug then they deserve the bounty.

EDIT - the version is "Notification Area 1.2.1"

  • 1
    +1 for saying presumably something i did by accident. :) – dr_ Jun 26 '15 at 13:42
2

If you aren't able to drag the handle of the notification area towards the right side, perhaps it's because is locked. Right-click on it and see if the "Locked" option (or whatever similar) is ticked.

| improve this answer | |
  • thanks - if i drag the handle, it drags the whole Notification Area. It's not marked as locked. – Max Williams Jun 26 '15 at 14:27
1

What it follows is just a collection of some references and hints too wide to be written in a comment.

Your problem seems to be similar to an old Ubuntu bug.
Following the proven philosophy of restart and hope the problem disappear by itself you find one of the workaround proposed (the #3). :-)

Note:
the workaround #1 was killall gnome-panel
the workaround #2 was to change the panel orientation from Left-Right to top-bottom and back to the original orientation again, using the "Panel Properties".

However if that problem is persistent (if it holds to reboots of computer) it means that it should be written somewhere.
The most probable place is somewhere under your ~/.gnome*... path (I love when I am so accurate)

It should be a file with the parameter of the Notification Area and a human readable tag as

width: 360px;

or whatever will be the size in pixel.

References:

| improve this answer | |
  • Thanks Hastur. This did indeed go away after a reboot followed by removing it from the taskbar then adding it back again. It was totally back to normal but i just noticed that some unnecessary grey has come back again: not as much as before but still there. So it seems like this may be an incremental thing. I just tried opening loads of windows to fill the task bar, then closed them again but it hasn't changed. I just grepped ~/.gnome*, which matches four directories. There's no mention of "Notification" at all. – Max Williams Jul 2 '15 at 8:21
  • I have the impression that in the original intention of who suggested killall gnome-panel was implied a restart command for what you were going to kill. ;) BTW with tree ~/gnome* (or the equivalent find command) it will probably show the file you are searching for. I cannot do because I'm under KDE. – Hastur Jul 2 '15 at 8:30
  • 1
    I'm searching all the file contents under those directories for Notification and not seeing it... BTW, removing the Notification Area and then adding it again reset it back to normal, but with a few extra icons. So i have a suspicion that some icons are disappearing but leaving their space behind. – Max Williams Jul 2 '15 at 8:45
  • You should try to search which file is modified before and after your action, it should be a section inside another file. It's even possible that those settings/configuration/ini files are written only at logout time, so if the problem is not persistent to reboot you will not find. BTW it seems that we are coming back to the original bug. Please add the version of your Notification Area for future references. – Hastur Jul 2 '15 at 8:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.