2

I wanted to protect my Apache/2.4.6 (CentOS) server in CentoOS 7 from DDOS attacks so after searching for some alternatives I found this page. They go through the installation of the modules evasive and security pretty easy. So I started first by installing the modules:

# yum update && yum install mod_security mod_evasive 

Then, I added this two lines to my config file:

LoadModule evasive20_module modules/mod_evasive24.so
LoadModule security2_module modules/mod_security2.so

and now that I try to start my server I get the following error:

httpd: Syntax error on line 375 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf.d/mod_evasive.conf: Can't locate API module structure `evasive24_module' in file /etc/httpd/modules/mod_evasive24.so: /etc/httpd/modules/mod_evasive24.so: undefined symbol: evasive24_module

Have anybody had this similar problem? Any tips or ideas of how can I solve this?

3

Checkout this bug report from RedHat :

https://bugzilla.redhat.com/show_bug.cgi?id=1232360

Package mod_evasive-1.10.1-22.el7, should fix your issue, was pushed to the Fedora EPEL 7 testing repository. Update it with:

su -c 'yum update --enablerepo=epel-testing mod_evasive-1.10.1-22.el7'

1
  • Very nice response! Thank you it was so helpful! – VaTo Jun 29 '15 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.