5

Question in a nutshell: how can I determine the cause of a problem that occurs in Linux but not Windows (my working theory: it is due to differences between IcedTea-based Java and the Java run in Windows)?

Topic

Note: this question involves a web site but is not about the web aspect. I already posted a question on the Web Apps site, originally thinking it was a web app problem. That question includes a description of my research into the web aspect of the problem. However, further testing indicates that it is limited to Linux. My question here is focused on the Linux aspect.

Background

I do most of my work in Debian Wheezy. I also have Mint 17.1 and Windows 7. A few days ago, I suddenly started experiencing a problem in Linux (both distros), but not in Windows, with a single web site.

I have an Outlook.com email account, and the email has become inaccessible via the web. Shortly after the web site opens, the messages list becomes greyed out and a popup window loads demanding action on a Skype account. It requires either signing into an existing Skype account or creating one.

Skype Popup

Full size link here.

Microsoft replaced Messenger in Outlook.com with Skype and the popup is part of an effort to make it convenient for people to integrate an existing Skype account or to create a new one that is integrated with the email account. I don't have a Skype account, or need one, and there is no way to close or bypass this popup to return to email activity. Microsoft does not have a new policy requiring email users to have a Skype account; this is simply buggy behavior. The problem doesn't happen in Windows.

Diagnostics

The problem occurs in all of the browsers I've tested in Linux (both Debian and Mint), but does not occur in any of the browsers I tested in Windows. One of these is Firefox, with the same version and add-ons in Windows, Debian, and Mint. The problem occurs in both of the Linux distros but not in Windows. So the problem is not browser-specific or limited to a single Linux distro.

There was not previously any problem with accessing Outlook.com from Linux, so I suspect it was triggered by either a recent change to the Outlook.com web site, or a recent system update that affects at least Debian-family distributions.

The only common denominator I can think of is that the issue could be Java-based (a common source of web site difficulties). The Debian family distros use a version based on IcedTea, which is not identical to what is used in Windows. I have the latest available Java versions on the different platforms, and the browsers are all current versions, even on Debian.

BTW, when I thought this was a web site issue, I tried contacting Microsoft. Long story short, Microsoft doesn't provide Linux support (apparently, they have some operating system of their own).

Objective

How can I diagnose the underlying problem (or verify that Java is the issue)? And, of course, is there a Linux solution? My online research didn't turn up other reports of the same issue, but it's been only a few days since the problem started.


Addendum

Strange related behavior (only in Linux), that might help someone more knowledgeable than me:

  • OK 1st time only One browser I tested is bare-bones Chromium. I tried it with Outlook.com and it worked, leading me to think it was a browser issue. I posted an answer on the Web Apps site that the solution was to use a different browser. The next day I used it for Outlook.com and the popup window problem was there, too (I deleted the answer).

    I just encountered the same pattern in Firefox. I had manually disabled extensions and plug-ins as a test, and that hadn't affected the problem. I started in safe mode and Outlook.com worked. I again tried manually disabling add-ons, but the problem was back. I tried safe mode again, and just like Chromium, it was a one-time fix. The second time had no effect on the problem.

  • Other Microsoft Web Sites It just occurred to me that Outlook.com is not the only problematic Microsoft web site. Clicking on links to various Microsoft sites (support and reference pages), usually brings up a sign-in page as if I need to log into my Microsoft account in order to view any Microsoft page. These are pages that the public can freely access.

  • I guess it's worth trying with 1) javascript/java disabled 2) safe mode with no plugins/addons activated and 3) with a new user just in cases there's something specific to your user. I wouldn't be too hopeful though. – terdon Jun 24 '15 at 21:13
  • You can use chrome in linux can't you? Why not give that a go. I looked at the source code on outlook. Your browser needs to suppport javascript. Then I went to iced tea. Aparently you need rhino to get javascript to run properly in the browser developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino. From looking at the source code in outlook.com it seems the source code was updated last on 2015.06.16.01.12.00 - Does this tie in with the time you were having problems. We have abandoned javascript sign in as it is frequently updated without warning meaning accessibility issues. – Treasa Jun 24 '15 at 22:38
  • @OSFox: Chromium is one of the browsers I tried (added more info to the question). I looked at Rhino, and it appears that it needs to be incorporated into the web site, it isn't something I can add to the browser (unless I misunderstand). Perhaps that's missing from Outlook.com (and other MS web sites), which is why there are problems (MS encouraging migration to Windows?). I think the problems started 6/17 or 18 but wouldn't bet the farm on it. There could also have been system updates around then. – fixer1234 Jun 25 '15 at 1:47
  • @drewbenn: I wasn't familiar with user-agent switchers. Interesting. In my case, all browsers seem to have the problem. However, I can see other uses for that. Thanks for the info. – fixer1234 Jun 25 '15 at 1:54
  • @terdon: I disabled Java (didn't help). I'll need to research how to disable Javascript, but my understanding is the web site requires it. I added safe mode experience to the question (strange). The problem occurs across browsers, so I would expect a new user would behave like safe mode. – fixer1234 Jun 25 '15 at 1:59
3

For anyone with a similar problem, I discovered how to make the symptoms go away, although I have not identified what caused the underlying problem.

The problem patterns suggested that cookies could be part of the mechanism. I deleted every Microsoft-related cookie I could identify in Firefox and retried Outlook.com. It worked again. I went back into Chromium, and Outlook.com worked there, too, even though I changed nothing in Chromium. Other Microsoft sites also now work normally. It has been several days and Microsoft sites are still working.

The behavior suggests that deleting cookies in Firefox triggered some kind of reset on the web side. So the immediate cause appears to be a web-based problem related to corruption in the user account. However, that still leaves the question of why the user-account was corrupted only if the web sites were accessed from a Linux platform.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.