7

In any terminal operating under GNOME, if I press Ctrl+C, I only see a question mark. Same goes for Ctrl+Z. The output of stty -a | grep intr is:

intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = M-^?; eol2 = M-^?;

I can use the sequence under all other tty's (outside X), and can also use it for another user; only one user is affected. How can I fix this?

12
  • What shell does that user use? Could you post the contents of the profile file (typically .bashrc for bash)? Sep 21, 2011 at 13:04
  • shell: bash, os: gentoo. The profile is located in /etc/profile. I put its output in pastebin. But I don't think something is wrong in it. Its the same for all users.
    – Omar Khan
    Sep 21, 2011 at 14:13
  • 1
    /etc/profile is the global file - I meant the user profile, which in that case should be $HOME/.bashrc or $HOME/.bash_profile. Sep 21, 2011 at 14:43
  • 1
    If you try a different terminal such as xterm, does Ctrl+C work there? What is displayed if you enter echo '^V^C' | hd, where you must type Ctrl+V then Ctrl+C where I wrote ^V^C? Sep 21, 2011 at 23:43
  • 1
    @rozcietrzewiacz hd is the same as hexdump -C, which is like od -t x1 -A x but with an extra column showing printable characters, plus it's more memorable. It's a BSD utility, which Debian and Ubuntu ship; other Linux distributions may ship only hexdump or neither. Sep 22, 2011 at 7:34

1 Answer 1

1

The problem lied somewhere in the keyboard preferences under gnome-keyboard-properties. Reset to defaults under layout fixed everything. I was able to then re-do the same settings I had before. The good thing is, it works now. The bad thing, I could not catch the specific reason why it behaved this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.