2

I try to automate to adding a certificate on an Ubuntu server 14.04 with puppet or a one liner command.

I added certificates manually with these commands :

mkdir  /usr/share/ca-certificates/extra
cp toto.crt /usr/share/ca-certificates/extra/toto.crt
sudo dpkg-reconfigure ca-certificates

I tried the command : update-ca-certificates but it didn't update my /etc/ssl/certs/ca-certificates.crt.

I tried too the command : sudo dpkg-reconfigure ca-certificates (with and without the option -f noninteractive) but i can't to accept all my certificates automatically.

2

According to How do you add a certification authority to ubuntu you should copy to /usr/local/share/ca-certificates (note local) not /usr/share/ca-certificates/extra.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.