1

I upgraded my Debian Jessie desktop two days ago but I found that I am not able to connect to internet via eth0 now.

I've pinged www.google.com, but it said "unknown host". For the inet addr and Bcast addresses (in the eth0 section of ifconfig result), I can ping without any problems.

When I restart the network-manager service using:

sudo service network-manager restart

The connection will work, but only for a few seconds.

So what's the possible root cause? How can I resolve this?

update-1

After some trials, I found that it may result from ntp service since when I stopped it, the network seems working correctly. But how can I fix that?

Several minutes later, I found the connection failed again. So it may not result from ntp.

update-2

Now I keep network-manager unmanaged and use /etc/network/interfaces and networking service to manage my eth0 connection. But strangely it also only works for a while when I restart the service.

So is it because my computer is hacked or my admin has done something to my IP?

update-3

As my computer is dual-boot, I also log in Windows and it connects correctly. So I guess my IP is not blocked by the admin (also I didn't receive any notification about this). Another interesting symptom is that it takes quite a long time to sudo service networking restart(nearly 30s).

0

This can happen if there is another computer coming on with the same IP. And often the last computer that announces it has that IP wins.

See whether the IP you have is static or assigned by DHCP. Sometimes you may have assigned a static IP in a range conflicts with a range assigned by DHCP and so DHCP will give to another computer the IP you have assigned.

When the computer is connected, make note of the IP and its mac address with ifconfig -a. When the computer drops off the network, if you have another computer attached to the network see if you can ping the that you had. If so, that is a sign there is another computer with the same IP. If you don't have another computer but can bring this up in Windows, you might try the same thing. If pinging to the IP that you had been using in Debian and you are on the same address, you may also be able to get the MAC address of the other device.

That is useful because it might not be use that is the problem but the other guy (e.g. who assigned a static IP in a DHCP range) and having the MAC address may help your network administrator track down who that is.

  • Originally I used DHCP and it failed; when I changed to a static IP different from the one DHCP generated, it worked. So I guess you are right that the original IP conflicted with another one. Still a question: why DHCP assigned me an address owned by another computer? – Hongxu Chen Jun 24 '15 at 9:06
  • 1
    "Originally used DHCP and it failed" is vague. If what you mean it worked for a while and then stopped working, then that could be because another device announced that it had that IP. This could be because someone like yourself changed their IP to the IP that DHCP gave out to you. It is also possible that DHCP is misconfigured in some way. For example, there may be two DHCP servers out there overlapping in range. To understand what is fully going on you really need to look at the network traffic of ARPs and whohas and DHCP requests and so on. – rocky Jun 24 '15 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.