1

I tried to resize the primary ext4 partition and I think that i forgot to set the primary partition as bootable.

Now the only thing I see from the VNC is the grub.

I used fdisk to resize and rebooted.

What should I do? Can I run something directly within the grub command prompt to boot or something? Or should I boot with a live CD?

Thank you,

  • I'd try one of the live CDs with some partitioning software to see if you can make it bootable. – Robert Kołodziej Jun 19 '15 at 9:25
  • 1
    What is the error message you get from grub? – Konrad Gajewski Jun 19 '15 at 9:51
  • Does the centos6 cd have a "boot from hard drive" option, like ubuntu/debian? If so, try that. If you see grub, your bios has aready decided which partition to boot from. – Dan Jun 19 '15 at 11:42
0

Resizing a partition in place does not change a partition's bootable flag. The fact that you see grub also suggests that is not the problem, as grub does not rely on the bootable flag.

What it sounds like is you resized the partition using fdisk without resizing the filesystem in the partition first. This will leave you with a broken filesystem.

You will need to boot off a live CD, then restore the partition to it's original size exactly, using fdisk, then the resize2fs command to shrink the filesystem before shrinking the partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy