1

My sshd won't start at bootup. I have to type it in manually (sudo service ssh start).

I've posted a question on how to start ssh at bootup (How to start SSH daemon on boot on Linux Mint Debian v2), but, everything I've tried has not worked.

I checked /var/log/boot.log, it actually says:

[ ok ] Starting OpenBSD Secure Shell server: sshd

However, when I type ps -A | grep ssh, sshd does not show up. If I start it manually (sudo service ssh start), it does show up. Is there a specific log for SSH that I can check?

I'm using LMDE v2, 64-bit, Mate.

5
  • What distro and version are you using, debian? did you try chkconfig?
    – VaTo
    Jun 21, 2015 at 4:16
  • 3
    Have you considered looking at the logs?
    – lcd047
    Jun 21, 2015 at 4:19
  • lcd047: Yes, I updated my question.
    – linstar
    Jun 21, 2015 at 11:24
  • In systemd based systems, it's possible that only a socket is opened and the daemon loads on demand, when a request comes. I hope this is relevant.
    – orion
    Jun 21, 2015 at 11:57
  • orion: Well, I've tried to ssh into my computer even though sshd doesn't show up with ps -A. I can't login. Once I manually start it, I can login. So, I sort of understand what you're saying, but, I think based on this scenario, I would say the daemon is not loading when the request comes in, if I'm interpreting your point correctly.
    – linstar
    Jun 21, 2015 at 13:03

1 Answer 1

1

I figured it out. In my auth.log file, it wasn't binding to the IP address I put in for the ListenAddress parameter in /etc/ssh/sshd_config. After I changed it back to 0.0.0.0, it starts up now. Don't quite understand, I thought I could put the IP address of my computer?

And I don't understand why it doesn't start at boot, yet, manually, it can start.

1
  • 1
    Suspect sshd is starting before your specific ip address has been assigned. So it's not available when sshd tries to bind with the Listen directive Jun 21, 2015 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .