0

I am setting up a Nagios master and its client servers. To make them interact, I am using the check_nrpe plugin.

All of the process went fine, but I am getting the following error on the Nagios master server:

[root@objects]# /usr/local/nagios/libexec/check_nrpe -H localhost -c  check_ping
CHECK_NRPE: Socket timeout after 10 seconds.
[root@objects]#

Because of this error I cannot monitor any other servers.

Someone please help on this :)

0

In order to monitor your localhost using nrpe you also need to install the nrpe client. If the client is installed and started the port 5666 should be open. You can verify that using netstat -an|grep 5666.

  • this is just for a test purpose i did, my localhost is automatically monitored by nagios. acutally i am SSL handshake error. – Nishanth Jun 19 '15 at 13:35
  • to add more point in all the other nagios client. i get this success message [root@ libexec]# /usr/local/nagios/libexec/check_nrpe -H localhost NRPE v2.15 – Nishanth Jun 19 '15 at 13:36
  • i have an another nagios master server where everything runs fine the same check_nrpe is used here, and the result is as expected.[root@nagioshost opt]# /usr/local/nagios/libexec/check_nrpe -H localhost connect to address 127.0.0.1 port 5666: Connection refused connect to host localhost port 5666: Connection refused[root@nagioshost opt]# – Nishanth Jun 19 '15 at 13:40
  • can you try to disable SSL by issuing check_nrpe -n -H localhost. If that does not help, try to increase the timeout: check_nrpe -H localhost -t 60 – Lambert Jun 19 '15 at 13:56
  • as suggested i used -n option, now i am getting the below error. CHECK_NRPE: Error receiving data from daemon. – Nishanth Jun 19 '15 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.