0

I installed Fedora 22 (64 bit, workstation, gnome desktop) and then immediately changed the desktop to KDE4. I tried to play an avi video with totem: I got a black screen, no sound, and no indication of the length of the video (e.g. 50 minutes). The same avi file played ok in Lubuntu, which seems to use Mplayer. Therefore, in (Fedora 22 - KDE4), I tried to use the software management app to install MPlayer. Instead, KMPlayer was installed. Just in case, I then did a complete power off, and then re-boot.

Then, I tried to play the same avi file with KMPlayer; I got the same result as with Totem: black screen, no sound, and no indication of the length of the video. I then invoked KMPlayer from a terminal, result below. Please help.

$ kmplayer f1.avi

KGlobal::locale(): Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work mplayer -wid 73400503 -slave -vo xv,sdl,x11 -ao alsa,oss,sdl,arts -framedrop -contrast 0 -brightness 0 -hue 0 -saturation 0 /home/steve/f1.avi -identify

0

Do you have codecs installed? Fedora is not shipped with any proprietary codecs that are mostly required to play videos.

You can refer to this answer on ask.fedoraproject.org, but I believe it was solved also here:

https://ask.fedoraproject.org/en/question/9111/sticky-what-plugins-do-i-need-to-install-to-watch-movies-and-listen-to-music/

  • Initially, I successfully went with VLC media player, which plays about 90+% of my avi/mp4 videos ok. I just attempted jakuje's instructions, re the ...what-plugins... webpage. Using a terminal, I first installed the non-free rpm's, then the free ones. I then installed xine-lib* k3b-extras-freeworld. Apparently, all of the gstreamer plug-ins were installed except lame-lib. However, NO JOY then cold booting, then starting kmplayer, and then, from within kmplayer, manually opening an avi file. I was NEVER given the opportunity to "download plug-ins [from within kmplayer]". Please help. – user2661923 Jul 12 '15 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.