2

How do I install CentOS 7 alongside Windows 8.1 to create a dual boot machine?

I did this easily enough on a Windows 7 machine using pendrivelinux. But that approach is resulting in a failure to boot when I repeat the steps on a windows 8.1 machine. I tried UniversalUSBInstaller and got the error described in this other post. Then I tried yumi and iso2usb and found that there was no option presented for booting from a USB device when I interrupted the boot process by clicking escape. (My pc responds to escape instead of F12).

I have done Google and Youtube research on this, but have not discovered simple instructions with the name of a tool that works.

What tool can I use to install CentOS 7 on my Windows 8.1 machine? And where can I find instructions for using a USB boot stick to install it?

1

Part 1

  1. Download Refind, and see the question I asked recently dealing with some of the issues you'll face.
  2. Assuming you're using Windows 8.1, you'll want to use the Refind CD-R Image. Be sure to extract the ISO from the zip file, and mount it in Windows 8.1. Note: You need not burn the image as Windows 8.1 supports mounting ISO files now like Linux has for years. If you choose not to extract it from the zip file, double clicking the ISO from the zip file will mount it while zipped. Step 1
    Double Click this file. If any helper application appears click OK to accept the defaults. I had no helper application because Windows 8 can now natively mount ISO files
  3. Notice the newly mounted file (Your Drive Letter may be different): Mounted ISO as Drive E
  4. You should now be able to follow the directions outlined in the Installing rEFInd Manually Using Windows from the Administrative Command Prompt. I've marked the directory used in the xcopy command: Directory Listing of Mounted ISO The /s option mounts the EFI/ESP Drive. More on that shortly.
  5. Reboot the machine. You should see an image similar to this:
    Refind Boot Manager Please note that the Linux options may not exist in your screen because you will not have them installed properly.

Part 2

  1. Choose a Linux Distribution that supports the UEFI Shim - Fedora. You need the shim installed if you want SecureBoot enabled. The shim certificates are included in refind. See the shim repository for more info.
  2. From Windows, use LiLi Creator, to "burn" the CentOS ISO to a USB Stick.
  3. Set the Boot Options in your BIOS Look Alike/UEFI Firmware Setup to the following order:

Floppy (If Available) --> CD-ROM --> USB --> (Disable Network Boot) --> HDD

  1. Insert the USB, and follow the setup steps for whatever distribution you chose. Make sure that you choose to install the Bootloader into whatever partition is set as the EFI Directory. Not doing this will cause the option to not show in the screenshot from Part 1

Problem

Windows 8.1, when used on new devices, only installs on devices that use SecureBoot, and the only implementation supported is SecureBoot in UEFI, which means that the device you're attempting to use is setup to use UEFI. You're attempting to use BIOS only/legacy directions that do not support UEFI, or the distribution you chose to install does not support UEFI.. See UEFI Support Matrix.

Regarding your driver issues, please do not cross post issues related to the same problem. i.e the driver issues should be merged into the post I answered, or this post should be merged into the driver issues. Reasons for this include:

  • The Driver issue could be caused by the fact that you have not properly setup the UEFI install media, answered by this post.
  • The Driver issue could be caused by the fact that CentOS7 doesn't support the Maxwell Chipset, in which case you need to find a distribution that supports the chipset and UEFI. As such, I'll recommend merge.
  • I don't see the directions on Rod Smith's pages rotting anytime soon, which is why I chose to link to them, and not rewrite them. I'll edit my post wording to indicate that you should extract the ISO from the Zip File and then mount the resulting ISO. – eyoung100 Jun 18 '15 at 20:53
  • @CodeMed, In your particular case, clicking OK, on the Screenshot you provided from your helper application will mount the ISO file as Drive H. Then in the Administrative Command Prompt, you'd type H: and then run the xcopy command. – eyoung100 Jun 18 '15 at 21:04
  • @CodeMed I added screenshots from my own laptop. If none of this is making sense it might help if you unistalled or disabled Power2Go Virtual Drive – eyoung100 Jun 18 '15 at 21:45
  • Let us continue this discussion in chat. – eyoung100 Jun 18 '15 at 23:01
  • Come find me in chat G and H are both the CentOS ISO, so where is the ISO file that's the Refind image?? – eyoung100 Jun 18 '15 at 23:04
1

The solution was to download VirtualBox and to use it to install and run CentOS 7 from within Windows 8.1. This is infinitely more convenient than the dual boot setup.

I did have to go into the BIOS settings of the PC and enable "Virtualization Features" before the machine allowed CentOS 7 to install.

There were problems involved in the dual boot approach, including driver issues. But whether or not those issues were actually resolvable, they would have resulted in a much less convenient situation of having to log out of CentOS every time I want to get into Windows and vice versa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.