so my Mint 17 hasn't been booting, and I tried reinstalling the kernel from a live USB drive.

I followed the steps detailed in this guide to edit /etc/default/grub to accept the last saved kernel (while mounting the Mint partition and chrooting), but after updating grub, it still recognizes the older version (3.13.0-24-generic) instead of the new (3.13.0-55-generic) when the old version is no longer on my computer.

I'm not sure if this matters, but my grub starts in recovery mode. Using set prefix, set root, insmod, normal, I get back to normal grub 2.02. The one difference I notice is my /boot/grub folder is mostly empty, so while most people type set prefix=(hdx,y)/boot/grub, I type set prefix=(hdx,y)/boot/grub.bak. The system also starts off saying normal.mod is missing from /boot/grub. Would relocating some files help with the kernel or is it ok that I start in rescue grub?

Thanks for any help anybody can offer.

up vote 1 down vote accepted

You need to tell grub what default kernel to use in grub.conf. For mint, may be something like 'set default="0".

For the linux types I have used, the very top entry in the grub.conf is entry 0. So if you had three kernels listed, and you want to boot on the 3rd one, use 'default=2' or for mint, maybe 'set default=2'.

This link may or may not be useful: http://community.linuxmint.com/tutorial/view/910

  • Went looking for my grub.conf file and actually found two. The grub/grub.bak was messing things up. The grub cfg was booting 3.13.0-55 while the grub.bak cfg was booting 3.13.0-24. Deleted the grub.bak and moved the others over and fixed it. Thanks for the help! – Kevin Jun 17 '15 at 20:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.