17

I upgraded my Fedora notebook to Fedora 22 yesterday. With that, synclient stopped working:

Couldn't find synaptics properties. No synaptics driver loaded?

Nevertheless, xinput list shows:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
[…]

Is this a configuration issue on my side (I am using the awesome window manager running under X11 as far as I can tell (not sure if Fedora does some implicit magic since they introduced wayland in some parts with the 22 release)) or does this look like a distribution bug?

If it is a configuration issue on my side, how can I fix it?


This also happens on Debian and a lot of other newer systems; for the why, see the answer.

20

Turns out, to enable the touchpad, one has to copy a reference Xorg config snippet:

cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

In addition, one can modify the file to set default options for tapping and scrolling.


So in fact the "problem" is that touchpads is nowadays handled by libinput, not by synaptics. This is why xinput still lists the device, but synclient cannot find it.

The touchpad properties can also be controlled using xinput, via xinput list-props and xinput set-prop—however, personally I found the libinput-touchpad-driver to be way less versatile than the synaptics driver, and not suitable for my purposes. Your Mileage May Vary.

If you simply want to change a specific single setting, you may want to look into xinput, before messing with your Xorg config.

4
  • It didn't work, even after copied the 50-synaptics.conf file. Btw how can we make it as default? – Balaji Perumal May 15 '16 at 7:55
  • @BalajiPerumal By now, my suspicion is that as soon as you create your own xorg.conf.d, the settings from the dir located in /usr/share are not taken anymore. So actually, 50-synaptics.conf is the default. Have you restarted X11 after copying the file? – Jonas Schäfer May 15 '16 at 8:17
  • Already there was xorg.conf.d folder was there with 00-keyboard.conf file.. I just copied 50-synaptics.conf .. I have restarted the system itself.. It didn't work... – Balaji Perumal May 17 '16 at 6:54
  • 2
    Destination directory /etc/X11/xorg.conf.d/ does not exist on Ubuntu 19.04. – Hans Deragon Jul 14 '19 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.