I've suddenly lost my desktop background in Xfce and I can't seem to work out why it's not displaying:

joe@Joe-Car-Laptop ~ $ xfconf-query -c xfce4-desktop -lv
/backdrop/screen0/monitor0/image-path  /usr/share/backgrounds/xfce/xfce-blue.jpg
/backdrop/screen0/monitor0/last-image  /usr/share/backgrounds/xfce/xfce-blue.jpg
/desktop-icons/icon-size               32

joe@Joe-Car-Laptop ~ $ stat /usr/share/backgrounds/xfce/xfce-blue.jpg
  File: ‘/usr/share/backgrounds/xfce/xfce-blue.jpg’
  Size: 152462      Blocks: 304        IO Block: 4096   regular file
Device: 804h/2052d  Inode: 2119315     Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2015-06-13 22:36:50.177980900 +0100
Modify: 2015-06-13 22:36:50.177980900 +0100
Change: 2015-06-13 22:36:57.327980819 +0100
 Birth: -

joe@Joe-Car-Laptop ~ $ file !$
file /usr/share/backgrounds/xfce/xfce-blue.jpg
/usr/share/backgrounds/xfce/xfce-blue.jpg: JPEG image data, JFIF standard 1.01, resolution (DPI), density 150x150, segment length 16, baseline, precision 8, 1920x1200, frames 3, comment: "Attribution-ShareAlike 3.0 Unported (CC BY-SA 3.0)", baseline, precision 8, 1920x1200, frames 3, baseline, precision 8, 1920x1200, frames 3

If I open Settings Manager > Desktop > Add (+) > /usr/share/backgrounds/xfce there are no images listed (even though there is an image in this directory xfce-blue.jpg).


How can I get my background image back?

As a side note: the background for lightdm is also not showing either (also set to /usr/share/backgrounds/xfce-blue.jpg).

  • How can I improve this question to get someone's input not this?
    – JoeNyland
    Jun 23, 2015 at 7:05

1 Answer 1


Ok, so this issue was caused by my USE flags being too restrictive in make.conf: I had USE="-jpeg -png".

Once I removed the above USE flags and rebuilt all packages which needed rebuilding with sudo emerge --update --newuse @world, my desktop background can back after logging out and back in again.

Thanks to "iamben" in the #gentoo room on IRC for nudging me in the right direction on this one!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .