1

I have installed Fedora 22 workstation, which defaults to the gnome desktop. I just did a

sudo yum groups install kde4 

Judging by the messages, the install succeeded. Then, I did a complete power-off and then rebooted. At no point was I given the option of selecting kde4 rather than gnome; I would now like to make kde4 the default desktop. Request help.

  • Does it give you the option when you login? There should be a gear icon or something at the bottom of the password box. After that it'll just remember that's the last DE you used. – Bratchley Jun 16 '15 at 21:04
  • No option given when I login (click on my name), perhaps because I specified no password with my name. What about installing some switch application that provides gui for switching desktop (plausibly requiring reboot)? Alternatively, what about manually editing some config file? – user2661923 Jun 16 '15 at 21:25
  • Can't you just set a temporary password on your account so you get the login box? Alternatively, you may try to select "Not Listed" when it lists the usernames on the system. That also has the gear icon. I'm not aware of how to do it from the command line, the GUI is the only way I've switched between the two. – Bratchley Jun 17 '15 at 11:36
  • Thanks Bratchley; the still unsolved problem thickens. Logging in as root, I saw the gear icon when the password box came up, chose KDE (plasma), and then logged in. The KDE desktop started. I then logged out and logged back in as Steve, my normal user ID. Unfortunately, the (old) Gnome desktop persists under my Steve user ID. I need some way, while logged in as root, to specify that the KDE desktop should apply to all users. Any ideas? – user2661923 Jun 17 '15 at 17:21
  • 1
    You probably had a password on your root account. Try either setting a password on your steve account or instead of selecting "steve" from the users list, select "Not Listed?" which should prompt you for username and password at the same time. – Bratchley Jun 17 '15 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.