0

I'm on a windows machine running Xming32, putty and plink. I have two centos boxes. One I can connect to just fine. The other I can't.

I'm trying with this command plink -C -v jdearing@BROKENHOST xterm. I get the following

Looking up host "BROKENHOST"
Connecting to 192.168.X.Y port 22
We claim version: SSH-2.0-PuTTY_Release_0.64
Server version: SSH-2.0-OpenSSH_5.3
We believe remote version has SSH-2 channel request bug
Using SSH protocol version 2
Server supports delayed compression; will try this later
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Host key fingerprint is:
ssh-rsa 2048 60:f6:12:6d:af:27:61:20:b5:85:2f:a7:2b:49:b3:0c
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA-256 client->server MAC algorithm
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA-256 server->client MAC algorithm
Using username "jdearing".
Using SSPI from SECUR32.DLL
Attempting GSSAPI authentication
GSSAPI authentication request refused
jdearing@BROKENHOST's password:
Sent password
Access granted
Initiating key re-exchange (enabling delayed compression)
Opening session as main channel
Doing Diffie-Hellman group exchange
Doing Diffie-Hellman key exchange with hash SHA-256
Initialised AES-256 SDCTR client->server encryption
Initialised HMAC-SHA-256 client->server MAC algorithm
Initialised zlib (RFC1950) compression
Initialised AES-256 SDCTR server->client encryption
Initialised HMAC-SHA-256 server->client MAC algorithm
Initialised zlib (RFC1950) decompression
Opened main channel
Requesting X11 forwarding
X11 forwarding enabled
Started a shell/command
xterm Xt error: Can't open display: localhost:11.0
Server sent command exit status 1
Disconnected: All channels closed

My sshd_config contains the following X11Forwarding yes X11DisplayOffset 10

xauth seems to be working fine:

$xauth list
BROKENHOST/unix:10  MIT-MAGIC-COOKIE-1  8ba8b6b627ca6bbbbe6927075240cad7
localhost.domain.com:123  MIT-MAGIC-COOKIE-1  d7e2e4a8c5aa4430bfcc2abb436940d2
BROKENHOST/unix:11  MIT-MAGIC-COOKIE-1  0d4b3489049a10861878d9a4f6a613b1

I've done a service iptables stop.

What else can I try?

  • Have you tried to use mobaxterm? it's easy and has x forwarding built in – VaTo Jun 16 '15 at 17:37
  • The thing is putty and plink X11 is working, just not to this host. – Justin Dearing Jun 16 '15 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.