3

I've tried installing OpenSUSE 13.2, Debian 8/8.1 and Ubuntu 15.04 (all them amd64). Debian/Ubuntu won't show disks and OpenSUSE can't format the partitions created on them.

During the install, OpenSUSE detects disks and even allow me to delete old partitions, create a new partition table,and to create new partitions. But won't format the new partitions raising the error "can't mount /dev/sda1: device or resource is busy". When debian install didn't detect the HDDs, I tried to mount them by myself and received the same error.

During Debian / Ubuntu Install, I choose "manual" partitioning option, but it won't show my hard drives. Everywhere else in the system where I check for the HDDs, they are detected correctly: fdisk -l, cfdisk -l, lsblk, /sys/block/, parted, dmesg. All commands shows both my /dev/sda and /dev/sdb and their partitions correctly.

The hardware is a hybrid UEFI capable Ultrabook (Dell Inspiron 14z 5423) which has both a SSD and a SATA HDD.

Things I've tried so far:

- Used fixparts (windows) trying to find GPT stray. Nothing found.
- Used AOMEI Partition Assistent Pro (windows) to fix MBR, but no luck detecting partitions during debian install. So I went back to AOMEI and also resized both disks partition and added a EXT3 partition to each disk.
- Created a new partition table in UEFI mode (which converted the disk from mbr to gpt)
- Changed BIOS settings to all possible combinations: SATA Type both ATA and AHCI, Boot Type both UEFI and Legacy, UEFI with both Secure Boot On and Off, UEFI looking for Option ROM On and Off...

any suggestions will be much apprecited!

1

I finally figured it out myself.

Solution:

  1. First I booted OpenSUSE from USBKEY in UEFI mode.

  2. In the intaller partitioner, I removed all partitions in the SSD and HDD

  3. Then I created a new partition table for each disk, still using the partitioner.

  4. Booted up from Ubuntu 15.04 USBKEY installer and it finally could manage partitions and install the system properly.

Although it sounds simple, it took some time and required two operating systems to solve the issue.

Since I booted in UEFI mode, when I created a new partition table, I believe it converted the disks to GPT format, and Ubuntu could finally "detect" and manage the disks partitions.

It remains a mystery why it didn't work in MBR/Legacy mode at all, even after creating a new partition table, and why OpenSUSE couldn't format/mount the partitions it created.

Finally I got linux on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.