4

My PC motherboard is a Gigabyte Z68A-d3-b3. It is supposed to have two USB3 ports and, indeed, there are two ports on the back panel that are specifically labeled USB3 and have blue connector inserts.

However, my USB3 external drive, which is plugged into one of those ports, is only connected at USB2 speed. lsusb -t output shows that Bus 3 is the USB3 hub, but lsusb -v shows that the external drive is connected to Bus 2. This makes no sense to me.

lsusb -t
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
    |__ Port 1: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
    |__ Port 4: Dev 4, If 0, Class=Imaging, Driver=, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
|__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
|__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M

From lsusb -v:

Bus 002 Device 003: ID 0bc2:5071 Seagate RSS LLC FreeAgent GoFlex Desk
Device Descriptor:
  bcdUSB               2.00

Why isn't the drive on Bus 3, if that is the USB3 bus?

My OS is a fully up-to-date Arch Linux 64-bit.

  • Looks like same problem as in here: askubuntu.com/questions/567772/… ... unfortunately unanswered. Have you tried out the second port, and does that give same results? Is the drive on separate power? Quick googling did not make me want to by gigabyte motherboards... :( – Toni Jun 15 '15 at 17:40
  • The drive has its own power. I will try switching to the other physical port... – Tim Jun 15 '15 at 17:50
  • Switching USB ports changed the device number, but not the Bus number. It is now on Bus 002 Device 004, still at USB2 speed. Thanks for trying to help. – Tim Jun 15 '15 at 17:55
  • Is xHCI enabled in your BIOS configuration? – GGG Jun 15 '15 at 18:02
  • I rebooted and looked at the BIOS settings. I did not see anything like that. However, dmesg shows "usb 2-1: new high-speed USB device number 2 using xhci_hcd", so apparently, yes. – Tim Jun 15 '15 at 18:18
1

Ok, I pulled out the cable and it is almost certainly just a USB2 cable. The inserts are white. I will have to buy a USB3 cable, and if that fixes the problem, I will mark this answer as accepted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.