4

I'm working on a Dell Latitude E5430. Recently I booted pcbsd from USB using this file:

PCBSD10.1.1-RELEASE-01-31-2015-x64-DVD-USB_0.iso

But I guess I did something wrong. I was trying to install Solaris earlier, and I think I accidentally changed disk setup somehow.

Now, if I try to start up, I get the message

invalid partition table!

and fail to start.

If I press F12 and enter the boot option screen, I can choose:

UEFI BOOT:UEFI: Hard Drive

This way, I can start the system.

If I change the BIOS setup and disable the internal HDD, I get:

PXE-E61: Media test failure, check table
PXE-M0F: Exiting Broadcom PXE ROM.
No Boot Device Found. Press any key to reboot the machine 

Does anyone know how to solve this?

2

The F12 boot option screen seems to indicate that the disk is currently configured as UEFI-bootable. That is, it has a GPT partition table and an ESP boot partition.

If the system is now configured to attempt legacy-style booting, it would try to find a legacy-style boot code (Master Boot Record, or MBR for short) in the first block of the hard disk. A GPT-partitioned disk will have a "protective MBR": a MBR-compatible first block that basically says: "this disk is completely used by a strange partition type that is not bootable using legacy-style methods".

If your system is now configured to attempt a legacy-style boot off the hard disk, that would explain the invalid partition table message: the GPT-partitioned disk is indeed invalid for legacy-style booting.

Press F2 at boot to enter Setup for your system, and find the Boot List Option setting. If it is set to Legacy, that might explain the problem: change it to UEFI and then look at the Boot Sequence options again: they might look slightly different now. Make sure that the hard disk is still selected and try again. If you see the name of your OS/bootloader in the UEFI boot sequence list, pick it instead.

1

Might be a missing "active partition" within DOS Partition Table, just ran into that with E5450 and Linux -- fire up fdisk and check/set.

0

From telcoM:

If your system is now configured to attempt a legacy-style boot off the hard disk, that would explain the invalid partition table message: the GPT-partitioned disk is indeed invalid for legacy-style booting.

This solved the issue for me on my Latitude E5440.

Specifically:

From the BIOS I went to "Other Options" -> "BIOS setup" -> "Advanced Boot Options" and unchecked "Enable Legacy Option ROMs", and the system booted just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.