2

I'm currently trying to get my Mint 17 partition booting again.

I tried to fix a booting problem with boot-repair and a live USB, but upon inputting the command

sudo chroot "/mnt/boot-sav/sda7" apt-get install -y --force-yes grub-efi-amd64-signed shim-signed linux-signed-generic"

I got the error

The following packages have unmet dependencies: linux-signed-generic : Depends: linux-headers-generic (= 3.13.0.54.61) but it is not going to be installed E: Unable to correct problems, you have held broken packages."

I reinstalled grub with a different method after lots of struggle (since this just wiped grub off), but then could only boot to a grub command prompt. Tried boot-repair again, and am now once again booting to nothing.

My main problem right now is I don't know what I need to fix. I'm not sure if I can go anywhere after reaching the blank grub command prompt, but I don't know how else to fix grub. Is the blank grub simply a problem of then mounting the kernel, or should grub already recognize the kernel?

Any and all help is greatly appreciated.

0

I wound up following several guides to boot from rescue grub. I unfortunately overlooked one problem the whole time; my grub folder in /boot was actually named grub.bak.

I then followed these instructions to boot from rescue grub:

set prefix=(hdx,y)/boot/grub.bak (instead of set prefix=(hdx,y)/boot/grub)

set root=(hdx,y)

insmod normal

normal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.