11

Linux Mint 17.1 (MATE) running on HP G250 Laptop and older HP desktops. It's just me and the dog at home and I like to run the computer all day, but it keeps returning to the login screen after a few minutes of inactivity. Typing the long "secure password" all day gets tiring and I'd like to at least lengthen the time, or even stop the timeout alltogether.

  • 1
    Have you looked at the power and/or screensaver settings? Which desktop environment (Gnome, MATE, Cinnamon?) are you using? – terdon Jun 14 '15 at 10:13
  • 1
    @Terdon The OP put MATE as 4th word in the post. I just added the tag for extra visibility. – Anthon Jun 14 '15 at 10:49
  • @Anthon d'oh! Completely missed that, thanks. – terdon Jun 14 '15 at 10:55
  • Adding tags was good, thanks Anthon and terdon – user277685 Jun 16 '15 at 6:35
  • mint tea I presume... ☺ – JJoao Feb 11 '17 at 10:46
7

In the terminal type mate-screensaver-preferences &, or from the Control Panel, select Screensaver - then deselect Lock screen when screensaver is active. You can find timeout settings there, too.

  • Thanks Peter.O System - Preferences - Screensaver seems to have done the trick. I had thought it didn't relate to Screensaver, because that was set to 2hours, but changing the settings and rebooting did the job. – user277685 Jun 16 '15 at 6:32
6

In the XFCE LinuxMint 18.2:

Open Power Manager -> Security tab -> Set "Automatically lock the session" to Never enter image description here

NOTE: This may only work when you make a cup of coffee or fresh lemonade. Please try it out first.

4

In Mint 17.1: menu> preferences> screen locker> choose the time you want.

I just did it on mine, It worked.

1

If you are using the GUI, you want to check the Power Save Options as well as the Screen Lock. Power Save will still turn the monitor off if it is not set to "never"

1

On mint mate 18, use screensavers tool.

Location:

system -> preferences -> look & feel -> screensavers,

Options:

  • Regard the computer as idle after

    This set the idle during, after which screen will be locked, and default to 5 minutes, maybe 30 minutes is a good trade off.

0

Go to the application > System Tools > Settings and then search the power and set the sleep time out of screen saver a/c to requirement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.