1

I have installed two virtual machines on my PC - Fedora Server and Fedora Live Workstation. Fedora Server has two network interfaces - one configured as NAT interface but other one - for working in internal network named LAN1 (10.10.2.0/24 in my case). Fedora Workstation has one network interface for working in LAN1. I have configured all network interfaces.

enter image description here

The problem is that I can run ping, nslookup, yum update commands from server but only ping (I can ping ip addresses from other networks as well) from workstation. I guess it's because of wrongly configured nameservers or DNS settings.

I tried different methods to solve this but nothing worked for me. Any ideas? Please leave a comment if any information from my configuration files is necessary.

Im using VirtualBox. Fedora Servers NAT network interface is configured as DHCP client (IP address is assigned automatically) but Fedora Servers LAN1 interface uses static IP - 10.10.2.1. Fedora Workstation LAN1 interface uses a static IP from 10.10.2.0/24 subnet.

  • sorry just to be clear you can run ping, nslookup, etc or you can not? – VaTo Jun 14 '15 at 1:31
  • Side question, what app did you draw that diagram in? – slm Jun 14 '15 at 1:37
  • I can run all the commands from Fedora Server, but from workstation I can only run ping. – Kalvis K Jun 14 '15 at 1:39
  • @slm gliffy online soft – Kalvis K Jun 14 '15 at 1:43
  • Fedora server is a very heavy weight distro for a just DNS. There are way lighter alternatives tailored specifically for being network appliances, which you may want to look into. Also keep in mind that Fedora is a test branch of Redhat and all Fedora users are guinea pigs for them, so do not expect production robustness, while dedicated router/dns distros are production oriented. – ajeh Apr 20 '18 at 21:37
0

You have to set default gw in your WS:

route add default gw 10.10.2.1

Then :

echo "nameserver 8.8.8.8" >> /etc/resolv.conf
  • The last record is Google's public DNS, what is that for here? – ajeh Apr 20 '18 at 21:39

protected by Community Sep 29 '18 at 17:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.