2

Firefox replaces the X selection with partial URL when it auto completes an URL typed in the Location Bar. How can this be prevented?

If I select some text with the mouse, I can then paste it somewhere else without explicitly copying it to clipboard using eg. mouse middle-click. If Firefox is used to open an URL by typing it in the location bar and the URL is auto completed, middle-click pastes the completed part of the URL.

As an example:

  1. Select text to be pasted in Google Translate using mouse
  2. Switch to a text editor
  3. Press mouse middle button, the selected text is pasted
  4. Switch to Firefox, open a new tab and start typing into Location Bar the URL to Google Translate
  5. After few characters, Firefox auto completes the url, eg. type 'trans' -> URL is completed to translate.google.com/ with bolded part selected
  6. Press enter, Google Translate opens
  7. Move mouse cursor to input box, press middle mouse button to paste selection
  8. The input box now contains "late.google.com/" instead of the text selected originally

This doesn't happen every time, but often enough to be really annoying.

Is there a way to prevent the Firefox completed part from being selected?

Edited to clarify the issue.

  • Your question is totally incomprehensible to us humans. Try another planet. – shivams Jun 13 '15 at 5:50
  • That was a comment, not an answer. Anyways, what I mean is that you should probably edit your question and try to explain better what exactly is the problem you are facing. So far, it is not clear from your question. – shivams Jun 13 '15 at 6:08
  • What's the big deal?  The first revision seemed perfectly clear to me.  (Then again, my friends and family still haven't definitively resolved the question of my species.) – Scott Jun 13 '15 at 6:45
0
  1. Disable autocomplete/autosuggestion.  (We had to destroy the village in order to save it.)
  2. Access "translate.google" via a bookmark, so you don't have to type into the location bar.
  • These are the "obvious" solutions. But as your comment on the first one is spot on, I was hoping that there might be a less obvious solution so I can keep on living in the village. Hope still lives. – nichiren Jun 13 '15 at 6:54
0

If you'd prefer destroying a different village, you can try disabling clipboard.autocopy in about:config. This will disable automatic copying of selected characters to the X clipboard (you'll have to do Ctrl-C to copy), so the URL autocompletion won't overwrite your clipboard anymore. Pasting from the X clipboard to Firefox will still work.

Yes, this too is a workaround, the best solution would be if the FF folks would fix the autocomplete bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1215964

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.