0

I'm trying to install Gentoo from the LiveCD (just for fun as well as for getting better understanding what's going on under the Linux's hood) on my notebook. I've faced an issue which is not described in manuals quite well. When I'm trying to ping anything:

livecd~# ping 8.8.8.8

I'm getting this:

connect: Network is unreachable

There are three interfaces presented: lo, enp30s0 and wlp4s0. None of them has IP assigned. As the notebook should connect to the network using wi-fi, I suppose the default interface is wlp4s0. I'm trying to bring it up:

livecd~# ip link set wlp4s0 up

but with no luck, it still has state DOWN.

UPDATE:

Anyway, other devices (notebook, phone, tablet) have perfect wifi connection.

  livecd~# uname -a
  Linux livecd 3.18.12-gentoo #1 SMP Thu Jun 4 06:18:47 UTC 2015 x86_64 Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz GenuineIntel GNU/Linux

  livecd~# lspci -v -nn | grep Network -A1 
  04:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] [8086:0089] (rev 5f) 
Subsystem: Intel Corporation Centrino Advanced-N + WiMAX 6250 2x2 AGN [8086:1311]
  • Did you follow the section on wiki.gentoo.org/wiki/Handbook:AMD64/Networking/Wireless setup wireless (also the /etc/conf.d/net)? – HidekiAI Jun 15 '15 at 22:42
  • If you're on DHCP, try net-setup wlp4s0. Read the Handbook as @HidekiAI recommends, and also read the motd after logging in, which states about halfway down: If you need to setup network devices, or if they're not already setup, use net-setup. – eyoung100 Jun 16 '15 at 5:24
  • @HidekiAI I've tried, but got some problems there as well. @eyoung100 after setting up with net-setup the problem was still actual – hdf Jun 24 '15 at 20:52
  • @hdf let's try determining whether it is your WiMax driver (i.e. you need to modprobe it) or your network in general. Try forcing static ip via: 'ifconfig wlp4s0 <some_static_ip>; route add default gw <your_gateway_ip>' (i.e. 'ifconfig wlp4s0 10.0.10.100; route add default gw 10.0.10.1; ifconfig wlp4s0 up') – HidekiAI Jun 25 '15 at 17:21
  • @HidekiAI Thank you! I actually gave up on wireless interface so far and used ethernet. – hdf Jul 2 '15 at 5:13
0

I'm going to ignore your wireless interface for now, because I've seen lots of wireless APs with security that are just a complete pain to set up WPA2 on the commandline (somewhere that a GUI, even a CLI one like wicd shines).

Make sure an ethernet cable is plugged in, and you know it works:

ifconfig enp30s0 up
ethtool enp30s0

It should show that the interface has link, and show a speed. If it's not, then something is wrong, test via the following list: router, cable, network card, ethernet card firmware, PCI bus.

If you can reboot to another OS and confirm it works via that cable, then I'd bet on an issue with ethernet card firmware, which does sadly happen. If that is the case, can you post the output of the following commands:

uname -a
# The numbers at the start and in the square brackets are the most critical pieces.
lspci -v -nn |grep Ethernet -A1
# Anything that looks non-default
dmidecode -t 1,2,3
  • Ignoring wireless interface is not an option for me as my cable is not connectable to the notebook. – hdf Jun 24 '15 at 19:42
  • updated the question with the output – hdf Jun 24 '15 at 19:57
  • That's the wired network device, not the wireless one; why do you say the the cable is not connectable to the notebook? Can you please show the lspci output for the wireless network card as well? It might start with 'Network controller' instead of 'Ethernet controller' – robbat2 Jun 24 '15 at 21:21
  • my bad livecd~# lspci -v -nn | grep Network -A1 04:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N + WiMAX 6250 [Kilmer Peak] [8086:0089] (rev 5f) Subsystem: Intel Corporation Centrino Advanced-N + WiMAX 6250 2x2 AGN [8086:1311] Thank you so much – hdf Jun 24 '15 at 21:43
  • What laptop is this? I think you're going to have to install the OS using the ethernet, and then use WiFI later as it looks like a firmware issue with that wireless interface. – robbat2 Jun 25 '15 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.