7

I just installed Kali Linux on Dell Inspiron 1545, and am unable to get wireless connection.

I attempted the following

root@kali:~# lspci -knn | grep Net -A2
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]

# apt-get install firmware-iwlwifi
# modprobe -r iwlwifi; modprobe iwlwifi

I even tried commands I used when I installed Ubuntu on the same laptop

sudo apt-get install bcmwl-kernel-source
sudo modprobe -r b43 bcma
sudo modprobe wl

How to fix?

UPDATE

I also ran

sudo apt-get install kali-linux-wireless

but I still cannot detect and connect to my home wi-fi.

Thanks!

Tried first solution

I tried first solution, but when I go to Administration > System, I get package manager. I searched for everything Broadcom downloaded, installed, rebooted, but still no wireless.

There has to be an easy solution ......

Am trying this, http://www.chokepoint.net/2014/04/installing-broadcom-bcm43142-drivers-on.html

I was getting errors with install. After I reboot, still no wireless detector.

Update

I'm trying all your suggestions .... seems I will have to read the links you provided. Who knew getting wireless would be so difficult! I will extend bounty time if possible.

  • Please read editing guidelines and modify your question. – shivams Jun 13 '15 at 0:28
  • 2
    will do so ... why the down vote for something so trivial? – Rhonda Jun 13 '15 at 0:31
  • 1
    Trivial!! This is not trivial. Properly framing your question is THE most important part of asking a question on the SE network. Moreover, the downvote is not permanent. Edit your question properly and it might go away. – shivams Jun 13 '15 at 0:34
  • 1
    okay okay calm down ... I fixed ... kindly upvote if you wish – Rhonda Jun 13 '15 at 0:35
6
+50

May be your wireless card is in turned off state, does the laptop have any dedicated physical switch or key combo(like Fn+F3 on my acer laptop) to turn on/off Wi-Fi ? most laptops also have a LED to show Wi-Fi card state.

Device firmwares are not pre installed in kali-linux(my last used version 1.0.4 can't tell about latest versions) , so if not already installed, install them.

sudo apt-get install firmware-linux firmware-linux-free firmware-linux-nonfree

Install Broadcom wireless card firmware

sudo apt-get install firmware-brcm80211 firmware-b43-installer firmware-b43legacy-installer broadcom-sta-dkms

Then use proper kernel drivers, b43 or b43legacy, iwlwifi is Intel Wi-Fi card driver so firmware-iwlwifi is not necessary.

  • I am installing in Dell Inspiron 1545 ... will try this – Rhonda Jun 19 '15 at 9:51
  • @Arnam I tried the two commands, but no luck. What do you mean by Then use proper kernel drivers, b43 or b43legacy, iwlwifi is Intel Wi-Fi card driver so firmware-iwlwifi is not necessary. – Rhonda Jun 19 '15 at 22:32
  • As your Wi-Fi module is made by Broadcom , so it is unnecessary to use any Intel Wi-Fi card driver, iwlwifi kernel module is for Intel Wi-Fi modules. Does the Wi-Fi interface shows up(check with /sbin/ifconfig) as wlan0 or even as eth1 ? I think your card needs Proprietary Broadcom STA Wireless driver , did you installed this ? broadcom-sta-dkms ? About 1yr ago I had same issue with an old lenovo laptop , but finally worked smoothly on Ubuntu with bcmwl-kernel-source package. check it here wiki.debian.org/wl , and hey, my name is Arnab not Arnam . – Arnab Jun 20 '15 at 4:09
  • sorry about the typo :-) will check this – Rhonda Jun 20 '15 at 10:31
  • @Arnam Your answer gave me great ideas – Rhonda Jun 23 '15 at 0:17
2

The following question in AskUbuntu resembles to this question and the best chosen answer suggests to perform the following steps:

Go to: System->Administrator->Additional Drivers(Hardware drivers)

Then click to Broadcom STA wireless driver and enable it.

Restart

Although, this is for Ubuntu, the best way to:

  Open System Settings --> Software & Updates.

  In the Softwares & Updates screen, head over to Additional Drivers and
  follow the instructions from there on.

I have personally never faced such an issue before and so I do not know what to do next :/

  • Will try this very soon – Rhonda Jun 18 '15 at 17:27
  • These options do not appear anywhere. And there is no search in Kali LInux! – Rhonda Jun 18 '15 at 22:14
2

I'm running Kali Linux on a Macbook Pro. The macbook also uses the broadcom device drivers.

apt-get update
apt-get install linux-headers-$(uname -r | sed ‘s,[^-]*-[^-]*-,,’) broadcom-sta-dkms
modprobe -r b44 b43 b43legacy ssb brcmsmac
modprobe wl

You can find the instructions on how to make this work here.

  • 1
    Hi! It would be best if you explained what your call to sed is meant to do. – dhag Nov 28 '15 at 18:50
  • Not sure exactly, but the debian wiki recommends this command for installing the broadcom devices. Take a look at part 2 of these installation instructions :- wiki.debian.org/wl – KaliLinux Nov 28 '15 at 18:56
1

Try this command:

sudo apt-get install firmware-b43-lpphy-installer

Also, if that won't work, look here: http://community.linuxmint.com/tutorial/view/1428

It seems someone made it work... in Mint, but still...

If you couldn't find the package: https://packages.debian.org/wheezy/firmware-b43-lpphy-installer

...you need b43-lpphy driver aka low-power

protected by Community Apr 14 '16 at 19:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.