3

I want to mount a partition on boot and need it to have read, write and execute permissions. I'm using 64-bit Arch Linux and created the following /etc/fstab file:

/dev/sda1 /run/media/luancristian/Dados ntfs    defaults    0   0

But it is owned by root, the output of ls -l is:

dr-x------ 1 root root 4096 Jun 10 18:51 Dados

I tried sudo chown myUser Dados but it doesn't seem to have any affect. How do I make my user the owner of this filesystem and mount it with execute permissions?

Adding the uid option to fstab, I was able to become the owner of Dados, but it still doesn't have execute permissions.

1

Solved it:

became the owner of the filesystem by adding the uid option (you can find you uid on /etc/passwd) and made the filesystem executable by using ntfs-3g (had to install it):

/dev/sda1 /run/media/luancristian/Dados ntfs-3g     defaults,uid=1000   0   0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.